The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gid 99 is not permitted to relay mail...

Discussion in 'E-mail Discussions' started by NovaRod, Jun 25, 2007.

  1. NovaRod

    NovaRod Registered

    Joined:
    Nov 19, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    ...or has directly called /usr/sbin/exim instead of /usr/sbin/sendmail

    I get this error a few times on one of our sites that uses a double opt in for email.

    Do any of you know if there is an option I need to be setting on my server?

    Thanks for any help here. I haven't found anything on this yet.
    NovaRod
     
  2. hari_anj

    hari_anj Member

    Joined:
    Jun 24, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Hi,

    The issue is due to the exim mail trap file in the server.
    Remove that file from server and try again.
    ===============================
    ls /etc/eximmailtrap
    rm -f /etc/eximmailtrap
    ===============================
     
    #2 hari_anj, Jul 12, 2007
    Last edited: Jul 12, 2007
  3. everestrus

    everestrus Member

    Joined:
    Feb 2, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I had the same problem and I solve that
    check the permission for /tmp/ and /scripts/upcp --force
     
  4. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    I'm getting the same issue for a few days now.
    Can someone or cPanel staff confirm which is the recommended solution please?

    Many thanks,

    - Vince
     
  5. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    Update:
    My server support think this is the reason:

    Strange, because as far as I remember I have had this option selected for months and the Gid 99 error didn't happen until recently. :confused:

    Anyone else confirm or deny any of this?

    Many thanks,

    - Vince
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Perhaps you may want to submit a support ticket.
     
  7. dragon2611

    dragon2611 Well-Known Member

    Joined:
    Nov 30, 2003
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Check the UID/Group ID on the scripts folder.

    The new apache 2.2x with SUphp likes the scripts to have the UID and GID matching where as before it was UID with a GID of nobody for some files.

    chown -R username:username worked for me.
     
Loading...

Share This Page