Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Git dependency blocking yum update

Discussion in 'CloudLinux' started by IdleServ, Jul 17, 2018.

  1. IdleServ

    IdleServ Well-Known Member

    Joined:
    Oct 27, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    156
    Running CloudLinux 6 and it seems lvemanager-4.0-19.7.el6 now requires git to be installed which I'd rather not do as cpanel-git already provides a newer version.

    The yum update is automatically failing due to perl* packages being excluded by default.

    Whats the best solution to this?

    Code:
    --> Processing Dependency: git for package: lvemanager-4.0-19.7.el6.cloudlinux.noarch
    --> Running transaction check
    ---> Package git.x86_64 0:1.7.1-9.el6_9 will be installed
    --> Processing Dependency: perl-Git = 1.7.1-9.el6_9 for package: git-1.7.1-9.el6_9.x86_64
    --> Processing Dependency: perl(Git) for package: git-1.7.1-9.el6_9.x86_64
    --> Finished Dependency Resolution
    Error: Package: git-1.7.1-9.el6_9.x86_64 (cloudlinux-x86_64-server-6)
               Requires: perl-Git = 1.7.1-9.el6_9
    Error: Package: git-1.7.1-9.el6_9.x86_64 (cloudlinux-x86_64-server-6)
               Requires: perl(Git)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,864
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @IdleServ


    You won't be able to use cPanel's Git for this you'll need to install the dependencies in order to update. My own test server running CentOS 7 has these as well along with cPanel's git:
    Code:
    [root@server mysql]# rpm -qa |egrep -i 'perl-git|git-1.8.3.1-14|cpanel-git-2'
    cpanel-git-2.17.1-2.cp1170.x86_64
    perl-Git-1.8.3.1-14.el7_5.noarch
    git-1.8.3.1-14.el7_5.x86_64
    
    Keep in mind that cPanel's Git is being used directly with cPanel services.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. IdleServ

    IdleServ Well-Known Member

    Joined:
    Oct 27, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    156
    Great, thanks.

    The solution to this problem was:

    Code:
    yum install perl-Git --disableexcludes=main
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,864
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @IdleServ

    Thank you for updating with what resolved the issue for you!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Ryan Burke

    Ryan Burke Registered
    PartnerNOC

    Joined:
    Feb 4, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Tampa, Fl
    cPanel Access Level:
    DataCenter Provider
    Thanks @IdleServ, this has been eating at me for several hours.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice