Git repo - The system cannot deploy automatically

alanski

Member
Dec 16, 2015
5
0
1
Brighton, UK
cPanel Access Level
Root Administrator
I have successfully setup repos on github and automated deployments from github to my WHM server.
I have now tried a repo on a CPanel account.
I can push changes from my local laptop to the CPanel server no problem.
However the yaml file is not deploying automatically.
When I login to the push pull screen i see the message:

For deployment, ensure that your repository meets the following requirements:
  1. A valid .cpanel.yml file exists. For more information, read our documentation.
  2. No uncommitted changes exist on the checked-out branch.
I have linted the Yaml file below and it is valid, and I have a clean tree with no commits waiting.
Documentation doesn't steer me to any logs to check.
---
deployment:
tasks:
- export DEPLOYPATH=/home/path/folder
- /bin/cp -R web $DEPLOYPATH

So what's the problem?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Hi @alanski

The documentation here: Guide to Git - For System Administrators - cPanel Knowledge Base - cPanel Documentation includes some troubleshooting steps including some locations of logs.

Is there anything noted in the log files in relation to this:

Note:


This feature logs messages and errors to the following locations:
  • /usr/local/cpanel/logs/error_log — Errors and stack traces.
  • /home/username/.cpanel/logs/user_task_runner.log — Queue-related items.
  • /home/username/.cpanel/logs/vc_TIMESTAMP_git_create.log — Creation-related issues, where TIMESTAMP represents the time of the operation.
  • /home/username/.cpanel/logs/vc_TIMESTAMP_git_deploy.log — Deployment-related issues, where TIMESTAMP represents the time of the operation.
 

alanski

Member
Dec 16, 2015
5
0
1
Brighton, UK
cPanel Access Level
Root Administrator
I have gone thru the basic setup again.
I have a repo on local. I can add files and commit and push from local to Cpanel repo.
Tree is clean. Yaml exists at top of tree and is valid YAML format

Still the push/pull screen shows
"The system cannot deploy"

There are no deploy errors as nothing is deploying. This seems completely unusable as far as I can tell. Its frustrating as I use 3rd party deployment services to deploy from local->github->WHM with no issues and I wanted to by pass them and just go straight to cpanel.....
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!