The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GLib-ERROR : failed to allocate ... bytes

Discussion in 'General Discussion' started by deus207, May 25, 2009.

  1. deus207

    deus207 Registered

    Joined:
    Dec 2, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I've to install mod_mono through /scripts/easyapache and I've got error while compile this module (2.x). The same problem I got when compile with mono 1.x.

    PHP:
    ./../../class/lib/net_2_1_raw -./../../class/lib/net_2_1 -l none -c link -a smcs -b true -g true -m display_internalized false -x Descriptors/mscorlib.xml -x Descriptors/smcs.xml -x Descriptors/System.xml -x Descriptors/System.ServiceModel.xml -s Mono.Tuner.InjectAttributes,Mono.Tuner:OutputStep -s Mono.Tuner.AdjustVisibility,Mono.Tuner:OutputStep -s Mono.Tuner.PrintStatus,Mono.Tuner:OutputStep -s Mono.Tuner.RemoveSerialization,Mono.Tuner:OutputStep -i masterinfos/mscorlib.info -i masterinfos/System.info -i masterinfos/System.Net.info -i masterinfos/System.Core.info -i masterinfos/System.Xml.info -i masterinfos/System.Xml.Linq.info -i masterinfos/System.Runtime.Serialization.info -i masterinfos/System.ServiceModel.info -i masterinfos/System.ServiceModel.Web.info -i masterinfos/Mono.CompilerServices.SymbolWriter.info
    Assembly 
    `System.Xml.Linq, Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.Xml.Linq.dll) tuned
    Assembly 
    `Mono.CompilerServices.SymbolWriterVersion=2.0.5.0Culture=neutralPublicKeyToken=0738eb9f132ed756' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/Mono.CompilerServices.SymbolWriter.dll) tuned
    Assembly `System.ServiceModel.Web, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' 
    (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.ServiceModel.Web.dlltuned
    Assembly 
    `mscorlib, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/mscorlib.dll) tuned
    Assembly 
    `SystemVersion=2.0.5.0Culture=neutralPublicKeyToken=7cec85d7bea7798e' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.dll) tuned
    Assembly `smcs, Version=2.4.0.0, Culture=neutral, PublicKeyToken=null' 
    (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/smcs.exetuned
    Assembly 
    `System.Net, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.Net.dll) tuned
    Assembly 
    `System.XmlVersion=2.0.5.0Culture=neutralPublicKeyToken=7cec85d7bea7798e' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.Xml.dll) tuned
    Assembly `System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' 
    (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.Core.dlltuned
    Assembly 
    `System.ServiceModel, Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.ServiceModel.dll) tuned
    Assembly 
    `System.Runtime.SerializationVersion=2.0.5.0Culture=neutralPublicKeyToken=7cec85d7bea7798e' (/home/cpeasyapache/src/mono-2.4/mcs/class/lib/net_2_1_raw/System.Runtime.Serialization.dll) tuned
    GLib-ERROR **: gmem.c:156: failed to allocate 192 bytes
    aborting...
    ..............
    !! Command failed in '
    /home/cpeasyapache/src/mono-2.4': 'make EXTERNAL_MCS=false EXTERNAL_RUNTIME=false' !!
    Can anyone got this error and know, how to fix that?
    Or I must to open support ticket with this problem? )
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Offhand, the "failed to allocate" message often indicates one has run out of RAM. However, you may want to have our technical analysts take a closer look: http://tickets.cpanel.net/submit
     
Loading...

Share This Page