The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

*** glibc detected *** exim: using dk_remote_smtp transport

Discussion in 'E-mail Discussions' started by blkjck, Oct 28, 2008.

  1. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I am seeing a que of emails frozen while using dk_remote_smtp. My transport is using the pool of godaddys cluster of mail relay servers. I can't specify the IP of the transport gateway over another. When dealing with one specific IP of their cluster I get the error of "*** glibc detected *** exim: double free or corruption (!prev): 0x09fd3798 ***" after it connects to the mta.
    If I change the transport to plain remote_smtp, the connection is fine. The same IP will process the email and send it as normal. In my testing though, it is always this same box that dk_remote_smtp is having a problem with, it does not seem consistent failure though. It's seems some emails pass thru no problem. Several of the emails that failed looked to have had attachments. When another IP is chosen from the cluster, the email always sends no problem. To me is sounds like something on their end. This is the same IP that is blocking my upcp log being sent from cron.
    Just wanted some ideas to make sure it's not on my end... Anyone every see this before with theirs? I ran a force update and it says the the glib is a current. glibc-devel - 2.5-24.i386 The perms on the keys in domain_keys/ public and private are set to root/wheel. But on the folder private it's root/mail - public is root/root

    Thanks
    jack

    This is part of the log before the glibc detected.

    50-AUTH LOGIN PLAIN 250-8BITMIME 250 PIPELINING SMTP>> MAIL FROM: SMTP>> RCPT TO: SMTP>> DATA SMTP<< 250 Sender accepted. SMTP<< 250 Recipient accepted. SMTP<< 354 End your message with a period. SMTP>> writing message and terminating "." LOG: MAIN DK: message signed using a=rsa-sha1; q=dns; c=nofws; s=default; d=thedomainname.com; h=Received:Message-ID:Reply-To:From:To:Subject:Date:MIME-Version:Content-Type:X-Priority:X-MSMail-Priority:X-Mailer:X-MimeOLE;
    *** glibc detected *** exim: double free or corruption (!prev): 0x09fd3798 *** ======= Backtrace: =========
     
  2. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    *Bump*
    Add on
    I limited this error to emails that are sent by outlook express with attachments. If I modify the header in the spooler by removing one line of the X- headers generated from MSOutlookExpress the mail will send. No email attachment the email passes.

    I just open the message header, delete or modify a full line from the bottom set of X headers from outlook express. IE the underlined header you see below for X-Priority. If I remove that line or if any one of those are removed, the emails passes with DK without error.

    038 Date: Fri, 31 Oct 2008 13:08:22 -0400
    014 X-Priority: 3
    026 X-MSMail-Priority: Normal
    051 X-Mailer: Microsoft Outlook Express 6.00.2900.5512
    057 X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
    035 X-RFC2646: Format=Flowed; Original

    Alternately if I only modify the X-Mailer: to match Thunderbird it passes without glibc error.
    Is is possible the glibc error is being caused by godaddy's mail transport? Or is this local error with exim? It is not a permission error, if I just open and save the file with no changes, delivery will fail. Also if I change to the transport not use the DK, it passes with no modifications.
    Any help, thanks.
    jack
     
  3. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I was able to stop the glibc error at the transport by adding:
    headers_remove = X-MSMail-Priority: X-Priority
    in the dk transport before the signing with the keys.

    Code:
    dk_remote_smtp:
      driver = smtp
      headers_remove = X-MSMail-Priority: X-Priority
      interface = ${if exists {/etc/mailips}{${lookup{$sender_address_domain}lsearch{/etc/mailips}{$value}{}}}{}}
      helo_data = ${if exists {/etc/mailhelo}{${lookup{$sender_address_domain}lsearch{/etc/mailhelo}{$value}{$primary_hostn$
      dk_private_key = "/var/cpanel/domain_keys/private/${dk_domain}"
      dk_canon = nofws
      dk_selector = default
    
    If anyone can shed some light on why this error is occurring. I would like to pin point where the error is and correct it. I went back in my logs and determined this all started on 2008-10-17. My local copy of upcp update logs is purged back 10 days, so no update log. I do have a lfd check that shows there was an update done with several binaries that deal with exim and mysql were updated. thanks - jack
     
  4. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    this works for some e-mail messages. I still get a lot of errors.
     
  5. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I still have an open cpanel ticket for this. Glad someone else is seeing this error. Short update.
    As a quick fix take a look at your outbound authentication for outlook express, uncheck it as required authentication. The outgoing email will be validated by the popbeforesmtp checking. When the email goes pop3beforesmtp all my emails go through. Something in ACL, mime content scan with sender rate before going to DomainKeys for signing. Can't get the right combo for it to replicate for cpantech. I noticed my failing emails all have sent several emails from the sending rate header. CPan test emails only report 0.0 sending rate, their pass through without error.
    Emails that fail are html formated or with attachments. Plain text emails go through no problem with outbound authentication enabled. Still only with Outlook Express and Outlook as clients.
     
  6. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Hello blkjck,

    Thank you for your answer. The problem is that some of my customers are getting this error and it's impossible to call all of them and ask to change the Outlook settings. I can fix this by removing the DK for the domains affected but this is not a solution. Some of our e-mails that have attachements (pdf but I don't think it matters) are getting stuck too.
    Please keep me updated about the ticket you have with cpanel.
     
  7. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Are you by chance also using k2smtpout.secureserver.net as your entry the router list? Default setting for hosting servers on GoDaddy.
     
  8. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    No, I have my own servers. I have done some modifications lately but I do not think that matters. I am blocking all the yahoo addresses that do not exist in order to minimize the damage that yahoo is doing to me.
     
  9. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    If you can get one of these messages stuck in EXIM's outbound queue, open /etc/exim.pl.local in a text editor and change:

    local $SIG{'ALRM'} = sub { die "flock timeout"; };

    to

    # local $SIG{'ALRM'} = sub { die "flock timeout"; };

    After doing that, unfreeze the stuck message and see if it gets processed out of the queue.

    I've seen a similar issue before that was caused by corruption of the alarm handler. It would be helpful to know whether or not the problem you are encountering is related.
     
  10. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Thank you for the reply.
    I have some e-mail messages in the queue, I forced one but I still got the error.
    (** glibc detected *** exim: double free or corruption (!prev): 0x096a05b8 ***)
    If I remove DK it works, but I would like to keep DK if that is possible.
     
  11. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    Hmmm. That's a little surprising. The problem sounds almost identical to the issue that came up with $SIG{'ALRM'} in the past.

    If you can get a few messages stuck, open a ticket marked "ATTN: JD" with full details of the exim command you're using to force the message. If I can get a proper backtrace of where the bad call to free() is, it should be fairly straightforward to come up with a fix.
     
  12. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Didn't work on mine either.
    The ticket for mine is still open. I'll reply an attn on the last posting. Cpanel Level 3 gave the opinion that it is more likely with godaddy transport.

    This is where I traced it to.


    SMTP>> DATA
    waiting for data on socket
    read response data: size=22
    SMTP<< 250 Sender accepted.
    waiting for data on socket
    read response data: size=62
    SMTP<< 250 Recipient accepted.
    SMTP<< 354 End your message with a period.
    SMTP>> writing message and terminating "."
    writing data block fd=11 size=1604 timeout=300
    ---1 Get 0x99a8aa0 112 expand.c 3155
    ---1 Rst 0x99a8ad4 ** expand.c 5755 68224
    ---1 Get 0x99a8ad8 1408 dk.c 419
    --Malloc 0x99b7830 124 dk.c 420 68224 34225
     
  13. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    Looks like it's a bug in libdomainkeys 0.68 that was fixed in 0.69. Updating to the exim-maildir-4.69-15 RPMs from cPanel's BETA branch should fix the problem.

    I'll bring the issue to the QA department and see if we can speed up the process of moving the 4.69-15 RPMs down to the other releases.
     
  14. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    The exim-maildir RPMs in EDGE and CURRENT have been updated to 4.69-15 now, so simply running /scripts/eximup should correct the problem.

    RELEASE and STABLE are using older versions of the RPMs that should not be affected by this problem.
     
  15. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    This fixed my issue. GoDaddy relay MTA is running QMail and the header length issue seems to be what was in conflict. Many thanks.
     
  16. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    yes, thank you, it works for me too.
     
Loading...

Share This Page