The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GLIBC_2.3.2' not found

Discussion in 'General Discussion' started by Christleo, Jun 26, 2003.

Thread Status:
Not open for further replies.
  1. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Syntax error on line 220 of /usr/local/apache/conf/httpd.conf:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: /lib/i686/libc.so.6: version `GLIBC_2.3.2' not found (required by /usr/X11R6/lib/libX11.so.6)
    /etc/init.d/httpd start: httpd could not be started


    i met this error any 1 have any idea to fix? OS linux 8.0 after the /script/upcp

    cPanel.net Support Ticket Number:
     
  2. drose25

    drose25 Well-Known Member

    Joined:
    Apr 3, 2002
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Had the same problem (also running RH8.0). My datacenter guys upgraded Cpanel to the latest Edge release and recompiled apache to get it working. It's not entirely fixed -- I cannot compile apache with Freetype support and probably some other modules because libxpm (I think) is screwed up.

    It looks like the nightly update updated something it shouldn't have. :)

    cPanel.net Support Ticket Number:
     
  3. masood

    masood Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Yes, same problem here. Red Hat 8.

    Thank you cpanel guys for testing on our servers. Do I get a credit for this?
     
  4. fmalekpour

    fmalekpour Well-Known Member
    PartnerNOC

    Joined:
    Dec 4, 2002
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Same here, but on just one RH8 server, rest of the others work fine.

    cPanel.net Support Ticket Number:
     
  5. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    this has just also happened to me tonight

    this has just also happened to me also tonight. Redhat 8.0

    /scripts/easyapache option 1 has fixed it. but now I have no gd support for php and need it.

    cPanel.net Support Ticket Number:
     
  6. fmalekpour

    fmalekpour Well-Known Member
    PartnerNOC

    Joined:
    Dec 4, 2002
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    I have just fixed that. Not sure work for all.

    WHM -> Install an RPM -> try to install glibc and then glibc-common both with these options selected:
    Ignore Dependicies
    Force Install (required if reinstalling a package)

    Then start apache. Don't need to rebuild apache and it will work fine for us.

    PS: We have same problem on other RH8 boxes as well.

    Hope to be helpful.

    F.Malekpour

    cPanel.net Support Ticket Number:
     
  7. Darkedge

    Darkedge Active Member

    Joined:
    Aug 16, 2001
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    YES

    Just so others know. This fixed it completely for me. No more autoupdates for me.

    cPanel.net Support Ticket Number:
     
  8. chican0

    chican0 Well-Known Member

    Joined:
    Mar 26, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Los Angeles
    Thank you very much, F. Malekpour. This fix worked perfectly for me to be able to get GD support back for my server. I agree with Darkedge... No more Autoupdates. I changed my prefs to STABLE. I have too may sites which require PHP and GD Support.

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  9. Steve-PWH

    Steve-PWH Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Weeeeeeee

    Nice one just had the same problem.

    Strange how I just happened cos have been running CP7 since yesterday and was ok then

    Good job I tested CP7 on a none live server me thinks

    Yes the instructions above worked for me 2 :P

    cPanel.net Support Ticket Number:
     
  10. WII-Aaron

    WII-Aaron Member
    PartnerNOC

    Joined:
    May 12, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    This worked and got apache up and running but now my e-mail's down.

    Here is the error I get in outlook:

    The SMTP server returned an error. Account: 'aarons.net', Server: 'aarons.net', Protocol: SMTP, Server Response: '/usr/sbin/exim: relocation error: /lib/libnss_dns.so.2: symbol __libc_res_nquery, version GLIBC_PRIVATE not defined in file libresolv.so.2 with link time reference', Port: 25, Secure(SSL): No, Error Number: 0x800CCC60

    Again, it looks like it's a GLIBC error. Any ideas?

    Aaron

    cPanel.net Support Ticket Number: 16804
     
  11. WII-Aaron

    WII-Aaron Member
    PartnerNOC

    Joined:
    May 12, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Restarting Exim did it. Sorry... :)

    cPanel.net Support Ticket Number:
     
  12. cyansmoker

    cyansmoker Registered

    Joined:
    Apr 25, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    One question:
    will anyone at DarkOrb at least acknowledge the problem or is this the level of communication we must expect to have with them? (= zip)

    cPanel.net Support Ticket Number:
     
  13. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    i have fixed using the above option

    cPanel.net Support Ticket Number:
     
  14. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This has already been addressed in another thread. /scripts/rpmup will solve this.

    cPanel.net Support Ticket Number:
     
  15. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    We ran /scripts/rpmup on one of our servers which was having this SMTP error and it returned everything was up to date, what gives?

    cPanel.net Support Ticket Number:
     
  16. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    I think after updating glibc, exim tries to use the old one but its not there any more. restarting exim fixed thoes errors with e-mail for me.

    cPanel.net Support Ticket Number:
     
  17. cyansmoker

    cyansmoker Registered

    Joined:
    Apr 25, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Sorry, I cannot seem to find a sticky with a title like 'Important: how to fix last night's bad update'

    :mad:

    cPanel.net Support Ticket Number:
     
  18. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    FYI...

    A /scripts/rpmup + /etc/rc.d/init.d/exim restart worked for me. :)

    cPanel.net Support Ticket Number:
     
  19. dhecker

    dhecker Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    hmm..

    I don't see those rpm's in my 'install rpm' list! (FC2/yum) ?
    How can i do this fix?
     
  20. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    Look at the original Post data :rolleyes:
     
Loading...
Thread Status:
Not open for further replies.

Share This Page