Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Global Filter not Working

Discussion in 'E-mail Discussions' started by Steini Pe, Apr 2, 2017.

Tags:
  1. Steini Pe

    Steini Pe Registered

    Joined:
    Apr 2, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Thailand
    cPanel Access Level:
    Root Administrator
    Hello Guys,

    I am new to the cPanel forum, I am a long time lurker. I am having a problem with the cPanel Global Filter, The filter looks like
    Code:
    From: user@domain1.com and Subject matches "Manual Upgrade Required" redirect to some@email.com
    Now before we go further, I can confirm it works in the Test, the test gives me "It matched, redirecting to ..." but in practice this is what happens as shown below in the exigrep

    The exigrep from /var/log/exim_mainlog shows
    Code:
    
    2017-04-02 10:19:14 1cucbK-0004Jn-6s <= user@domain1.com H=mail-wr0-f171.google.com [209.85.128.171]:35753 P=esmtps X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no S=3096 id=CANVayFnzyJgQUrOkM=BTFiVQ23xVWn=oHByCBBVRFmRJc5sD=w@mail.gmail.com T="Manual Upgrade Required" for user@domain2.com
    2017-04-02 10:19:14 1cucbK-0004Jn-6s => user<user@domain2.com> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <user@domain2.com> MShEHSLQ4FimQAAAYovs7Q Saved"
    2017-04-02 10:19:14 1cucbK-0004Jn-6s Completed
    
    I have root access on everything, just not sure why this isn't working. What I can confirm however is that even if Global Filtering is not working Specific email filtering works, I created a test one and
    
    Event: failure
    Sender User: -remote-
    Sender Domain:
    Sender: user@domain1.com
    Sent Time: Apr 2, 2017 5:30:17 PM
    Sender Host: mail-wr0-f181.google.com
    Sender IP: 209.85.128.181
    Authentication: localdelivery
    Spam Score: 0
    Recipient: user@domain2.com
    Delivered To:
    Delivery User: xxx
    Delivery Domain: domain2.com
    Router: virtual_user_filter
    Transport: remote_smtp
    Out Time: Apr 2, 2017 5:30:17 PM
    ID: 1cucmC-0004fm-FG
    Delivery Host:
    Delivery IP:
    Size: 3 KB
    Result: Booh!
    
    So why would Global Filter not function while Email Filter for specific accounts work?
     
    #1 Steini Pe, Apr 2, 2017
    Last edited by a moderator: Apr 2, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can access the affected system to take a closer look at what's happening? You can post the ticket number here and we will update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page