The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gmail for Business Not working on Main Cpanel Account

Discussion in 'E-mail Discussions' started by 1Walter2, Jun 3, 2016.

  1. 1Walter2

    1Walter2 Member

    Joined:
    Dec 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Hi there.

    I run a small Web Development company.
    We host most of our clients websites and emails.

    Quite a few of our clients use gmail for business for their emails.
    And it works fine. Its as simple as changing to remote server and putting the gmail MX records in and all works fine.

    I had a suspicion that it would not work for my company since the domain name is the same as the primary server.

    Let me explain.

    Lets say my company is hostabc.com
    My name servers are ns1.hostabc.com and ns2.hostabs.com

    And since my email address is sales@hostabc.com I think there is an issue getting it to work.

    What I should have done is 2 years ago is setup my dedicated server under a different domain name like hostabcserver.com and make my company website like I would do for my clients and not share the same domain name as my dedicated server.

    I know if thats how I did it, it would work.

    But now here I am in this situation where my dedicated server that I use and my business webiste and emails share the same domain name.

    I am pretty sure it would still be possible for me to use gmail for business emails with my domain, but the standard way to configure it is not working.

    When I setup my MX records as I do for all my clients, it doesnt work and I get the following bounce back.

    Hopefully this info helps
    Code:
    ********************************************
    
    Delivery to the following recipient failed permanently:
    
    **Everything has been edited for privacy including ip addresses and domain names**
    
    
      myemail@hostabc.com
    
    
    Technical details of permanent failure:
    
    Google tried to deliver your message, but it was rejected by the server for the recipient domain hostabc.com by hostabc.com. [***.***.***.***].
    
    
    The error that the other server returned was:
    
    550-The mail server could not deliver mail to myemail@hostabc.com  The 550-account or domain may not exist, they may be blacklisted, or missing the
    
    550 proper dns entries.
    
    
    
    ----- Original message -----
    
    
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    
      d=gmail.com; s=20120113;
    
      h=from:content-transfer-encoding:subject:message-id:date:to
    
      :mime-version;
    
      bh=g3zLYH4xKxcPrHOD18z9YfpQcnk/GaJedfustWU5uGs=;
    
      b=oCgTy0VyiKTsgPM1RYvgkAW6c5gq2TA0IRjh9zIctyAIFituzB/4MxmhRIJRTn63eW
    
      u6mgCsFTpl4Q8rmho7Q0fwIelaY5kUyw0EX2dBKcmUEdvcrXbqpTFI3BBObpucNgLj5W
    
      dp4FeO+imVU5mfMgm+ekyDnMmLZgXsCTEUwX0Hc3f2txyXFnP/4YA8nRxz+oBYLn5IsT
    
      kcnIy5RlDqE58twvd93/K6IaxPKytOK7zaJOHQ53vgNxc+Os756Drq2HNuf72PYTTQAB
    
      hiShwg7UWJ6Yp2MTl2xPOpt5iulIMfeZMZ0dhfEWmHaETpsp0E++TeoO/r6uiIx2FGPQ
    
      Zzrg==
    
    X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    
      d=1e100.net; s=20130820;
    
      h=x-gm-message-state:from:content-transfer-encoding:subject
    
      :message-id:date:to:mime-version;
    
      bh=g3zLYH4xKxcPrHOD18z9YfpQcnk/GaJedfustWU5uGs=;
    
      b=Ttg8P2ZPUkgHVfRkRLbq7pqm9shzWETQ5vYZF2aDPc88oq/ExzBJG+Y7znaEQpYrIt
    
      mdamUQsSQXNnI2prDD7glemU83Mhd0p6eNL+i2ocZuct4fGO4ujVwIJcvysnnnhpSZTd
    
      +1moTPPseu3+/N6y3+27UTIF/lh+4nwsdIA9SbdWZiJa/fFfmEwnyTX//WEc7BK8OSjA
    
      s3PPynVCmmnC3dc0euo6Hj0yCgm90otl8D/DXgKcT3MWSX+r6XWM8OlEZBIDuct5hbdM
    
      dbgS1I9Py3YKq6V/2zQs40Hhw0eblU9Aj4hIOnhfZe2/tJ26tQzyh4Zf2k2NuQwMXQH4
    
      3V7A==
    
    X-Gm-Message-State: ALyK8tI5grMEuwugOVV7O6ggyB/MW0bvceWRriWMVxUejMZ1Uc/F5Do1KhZkw9Jg2W34aQ==
    
    X-Received: by 10.66.14.73 with SMTP id n9mr3010715pac.112.1464934925583;
    
      Thu, 02 Jun 2016 23:22:05 -0700 (PDT)
    
    Return-Path: <mypersonalemail@gmail.com>
    
    Received: from [***.***.***.***] ([***.***.***.***])
    
      by smtp.gmail.com with ESMTPSA id r86sm5219123pfb.21.2016.06.02.23.22.02
    
      for <myemail@hostabc.com>
    
      (version=TLS1 cipher=ECDHE-RSA-AES128-SHA bits=128/128);
    
      Thu, 02 Jun 2016 23:22:03 -0700 (PDT)
    
    From: My Personal <mypersonalemail@gmail.com>
    
    Content-Type: text/plain; charset=us-ascii
    
    Content-Transfer-Encoding: 7bit
    
    Subject: test
    
    Message-Id: <048A66FD-F250-4896-8318-23D768E9B1B5@gmail.com>
    
    Date: Fri, 3 Jun 2016 16:21:58 +1000
    
    To: My Email <myemail@hostabc.com>
    
    Mime-Version: 1.0 (Mac OS X Mail 9.3 \(3124\))
    
    X-Mailer: Apple Mail (2.3124)
    
    
    test
    
    ****************************************
    
     
    #1 1Walter2, Jun 3, 2016
    Last edited by a moderator: Jun 3, 2016
  2. webhostuk

    webhostuk Well-Known Member

    Joined:
    Sep 11, 2013
    Messages:
    55
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Website Owner
    Have you removed the localdomain entry for hostabc after adding google MX record ? I guess thats the issue.
     
  3. 1Walter2

    1Walter2 Member

    Joined:
    Dec 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Yep, done that. Do get a different error message now.

    ******************************
    The error that the other server returned was:

    550-Please turn on SMTP Authentication in your mail client.

    550-mail-wm0-f46.google.com [74.125.82.46]:32840 is not permitted to relay

    550 through this server without authentication.

    *******************************************
     
  4. 1Walter2

    1Walter2 Member

    Joined:
    Dec 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I fixed it, by giving the local domain a priority of 20
     
  5. ssfred

    ssfred Well-Known Member

    Joined:
    Jan 6, 2012
    Messages:
    62
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello

    Glad to know that the issue is fixed and thank you for sharing it with us.
    The error message doesn't appear to be related with the MX record preferences or priority values. It simply means that the mail client is trying to relay a mail through SMTP server without authorization. The issue can be avoided by enabling " SMTP authentication" setting in your mail client or downloading the mails first before attempting a mail delivery.

    If you receive authentication related messages while attempting mail delivery through webmail also, then it needs further investigation.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page