The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gmail not able to connect to my SMTP server

Discussion in 'E-mail Discussions' started by AL-Kateb, Jan 29, 2014.

  1. AL-Kateb

    AL-Kateb Active Member

    Joined:
    Feb 27, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Hello everybody, I am having a problem and I thought you guys could help.

    I'm adding another account to my Gmail account that I wish to send and receive emails from, when I choose the option to send email through "Mywebsite" SMTP, I provide my details and I receive the message:

    "Your other email provider is responding too slowly. Please try again later or contact the administrator of your other domain for further information."

    I have Exim setup on my server, and it's running on port 25 so I've chosen port 25 unsecured I still get this error.

    At first I thought IpTables might be blocking the connection for some reason so I disabled it and tried again but that did not help.

    The process is happening under 5 seconds so this can't be a timeout issue. The message is quiet clear! Taking too long! But it isn't. I have tried sending from outlook, and from webmail and it works just fine.

    So what can I do to troubleshoot this issue?

    I have posted this question on Google forums, someone suggested that it's because exim is using self-signed certificate, and he suggested that I disable advertising TLS, I do not think this is the issue, I was running this exact same setup and I never had this issue before, I recently have moved my websites to a new hardware and it is then when I started receiving this message.

    I am ABLE to send/receive using secure and unsecured settings using outlook or webmail, but not using this Gmail's feature.

    And BTW, gmail can connect to POP3 and receive messages as expected
    So any idea what this could be?
     
    #1 AL-Kateb, Jan 29, 2014
    Last edited: Jan 29, 2014
  2. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Still sounds like a firewall issue. Is there perhaps an upstream firewall (at your host perhaps)? Try running an nmap to see if all the ports that are expected to be open are in fact open.
     
  3. AL-Kateb

    AL-Kateb Active Member

    Joined:
    Feb 27, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I am able to connect to ports (25) and (465) using MS Outlook with no problem, and there are no IPs blocked I've flushed them all. And above all that I've disabled the firewall and tried it did not work. By default iptables is the firewall installed and I'm managing it using CSF.

    I was also able to connect to it using telnet, so no firewall issue here, maybe Gmail's has got some sort of blacklist it tests against? Even though my messages are being delivered to inbox I guess so I don't know.

    Should I submit a ticket or it isn't the kind of thing I can ask support for from cPanel?
     
    #3 AL-Kateb, Jan 30, 2014
    Last edited: Jan 30, 2014
  4. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Feel free to open a support ticket using the link in my signature. We'll be happy to take a look and if it turns out that it is not supported, we'll let you know, but we do try to guide you as much as possible to a solution.
     
  5. sahostking

    sahostking Well-Known Member

    Joined:
    May 15, 2012
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Cape Town, South Africa
    cPanel Access Level:
    Root Administrator
    What was the solution for this issue?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Are you experiencing the same issue? If so, could you elaborate on what solutions you have tried thus far? The original poster did not submit a ticket or post a ticket number for us to investigate further.

    Thank you.
     
  7. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    Aware that this thread is old but I would like to hear solution to this problem as it seems clients on my server are having the same problem. I tested this and found that issue can be partly solved by disabling CSF. Nevertheless in this case only combination with hostname as mail server+ port 465 + SSL works. only this combination works. When CSF is enabled nothing works.

    Can anybody offer solution to fix this problem ?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  9. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    This thread is discussing wrong login attempts and how to provide users to have more login attempts before being blocked, if they are entering wrong password.
    Here we have this option where GMAIL interface can be use as Outlook for example so user can check and send mails from their domains on my server , but through GMAIL interface. In the step where you need to enter this email access data, Google respond with "Your other email provider is responding too slowly". I tried different combination for the mail server (hostname and specific domain mail server) , port and encryption which is given but all failed. IP tables are flushed and nothing is helping except when I disable CSF. When firewall is disabled it is working but only option where SMTP server is server hostname, port 465 and SSL as encryption.

    What is this about ? I found some threads through the years but seems noone can solve this.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  11. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    Thanks, it seems this did the trick. I disabled this option and now Google verified my mail server with port 25 and TLS secured connection.
    However if I want to enter SMTP server as server hostname and select port 465 , this way it is still not working.
    Maybe it is still CSF. Where in CSF configuration should port 465 be opened ?
     
Loading...

Share This Page