Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

gnupg errors

Discussion in 'General Discussion' started by gopkris2005, Jul 31, 2013.

  1. gopkris2005

    gopkris2005 Well-Known Member

    Joined:
    Jan 9, 2007
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    I have received the following errors after install gnupg.. Anyone have idea??

    root@server[~]# php -i | grep gnupg
    php: gnupg
    relocation error: /usr/local/lib/php/extensions/no-debug-non-zts-20090626/gnupg.so: gnupg support => enabled
    symbol gpgme_check_version_internal, version GPGME_1.1 not defined in file libgpgme.so.11 with link time reference
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    What method did you use to install this PHP module? You should be able to install it successfully via:

    Code:
    yum install gpgme-devel
    pecl install gnupg
    However, it's a good idea to first uninstall/remove any changes you made with your initial installation.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. gopkris2005

    gopkris2005 Well-Known Member

    Joined:
    Jan 9, 2007
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for your reply... I have installed via WHM module installer, also tried with from source file. but still getting these errors.

    #php -i | grep gnupg
    gnupg
    php: symbol lookup error: gnupg support => enabled
    /usr/local/lib/php/extensions/no-debug-non-zts-20090626/gnupg.so: undefined symbol: gpgme_check_version_internal

    Anyother way to fix this issue?

     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you tried uninstalling this PHP module completely, and then reinstalling it via the method listed in my last response?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. gopkris2005

    gopkris2005 Well-Known Member

    Joined:
    Jan 9, 2007
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes, I have tried to uninstall this module and recompile with easyapache... Again, I had used your commands but still having this errors.


    root@server[/home]# php -i | grep gnupg
    gnupg
    php: gnupg support => enabled
    symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20090626/gnupg.so: undefined symbol: gpgme_check_version_internal
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Could you open a support ticket so we can take a closer look?

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. gopkris2005

    gopkris2005 Well-Known Member

    Joined:
    Jan 9, 2007
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for your update... I had submitted ticket - Id 4311931
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    To update, it looks like this was the result of the Cloud Linux repositories used on the system. Cloud Linux was installed, but the following files were configured for a standard CentOS installation:

    /etc/redhat-release
    /etc/yum.conf

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice