The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GoDaddy Dedicated Virtual and cPanel

Discussion in 'General Discussion' started by entrican, Aug 23, 2012.

  1. entrican

    entrican Registered

    Joined:
    Aug 23, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I'm new to cPanel but not GoDaddy. I recently purchased another dedicated server and discovered they no longer offer their old control panel so i added cPanel to the order.

    I have a domain that's sitting at Network Solutions (DNS is also there) and I use GoDaddy servers for a variety of applications - but mostly websites. I obtained a dedicated IP for the new server with cPanel on it and added an "A" record in my DNS at Network Solutions. I then purchased a wildcard certificate from GoDaddy and it appears to be installed correctly as I can hit https://anysub.mydomain.com and the test page shows up.

    Normally I would then go to the httpd.conf file and review where the DocumentRoot is. Upon examination, it appears the default location was set to

    My problem is that I can't get PHP pages to load properly when I place them in the indicated directory /usr/local/apache/htdocs for SSL. As I said, when I hit that address using the subdomain name I added my DNS at Network Solutions - it works. When I place a simple PHP file in that directory (/usr/local/apache/htdocs) it throws a 500 error. There must be something I'm doing wrong or have failed to do in order to set this up properly.

    I apologize if this question is repeating other posts, if anyone knows of prior discussion or solutions, i'd be happy to look over them - just need the link.

    Any help would be MUCH appreciated.

    Thank you,

    -Robert
     
  2. entrican

    entrican Registered

    Joined:
    Aug 23, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I forgot to mention that when I place a simple test.html file in that same directory (/usr/local/apache/htdocs), it works like a champ. For some reason, its acting as though PHP is not enabled - but only for that directory because it works if you use the http://1.1.1.1/~user/test.php.

    hope that makes sense.

    -Robert
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you have an extra IP, change the certificate to install onto that dedicated IP. SSLs aren't normally supposed to load under the default Apache directory but under the /home/username/public_html directory.

    Please note that we have a slew of posts about installing wildcard SSLs. There's also a script on installing them at this location:

    Wildcard SSL Installation Script :: The cPanel Admin
     
Loading...

Share This Page