The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Apps sending phpmail WHM error

Discussion in 'E-mail Discussions' started by tsediting, Aug 4, 2010.

  1. tsediting

    tsediting Member

    Aug 28, 2005
    Likes Received:
    Trophy Points:
    We are running a dedicated server housed in a well know datacentre in the UK, running cPanel 11.25.0-R46156 - WHM 11.25.0 - X 3.9
    on the OS CENTOS 5.5 i686.
    PHP is configured with 5.1.13 with openssl and all other mod cons.
    half our clients on the server use the standard on board email (mx records set to send from clients domain – standard setting on WHM). This works fine for them however a bunch of clients on our recommendation have switched to google apps as the spam filtering and webmail is second to none.
    Everything about their email is better apart from one small oddity, which I’ll explain in detail below.
    To make this nice and simple I am going to use some pseudo names and domains to describe the fault.
    We are going to call the standard whm mail clients:
    and the google apps users: = send mail, works perfect. = receive mail, works perfect. = send mail, works perfect. = receive mail, works perfect…APART from it will NOT receive local phpmail, IF the sender is another google apps user.

    When a Standard whm mail client uses a php script to send mail on our server it is sent from ‘’ , and the following occurs:
    ‘’ = send and receive, works perfect.
    If its a google apps users sending phpmail via the same method though, then‘’ = sends fine, and recipient receives. UNLESS the recipient is another google apps user on OUR server, they then will NOT receive the phpscript email!
    How did we discover this?
    long story, but after intense testing I can confirm it is only other google apps users on our server who do not receive email from phpmail scripts when the sender is also another google apps user.

    All of the settings have been checked, double-checked and verified, the SPF records and all other records are correct however there is obviously something not right. My solution Im thinking of right now is to somehow change all of the on board phpmail scripts to send from one separate domain, so instead of each user sending from their individual ‘’, instead all phpmail gets sent from ‘’.
    Does anyone know if this is possible? And if so how would we accomplish this?
    Thanks in advance.
    #1 tsediting, Aug 4, 2010
    Last edited: Aug 4, 2010

Share This Page