Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Google Backup Validation Errors

Discussion in 'Data Protection' started by Dezdan, May 11, 2018.

  1. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    After my server updated to v70.0.34, I stated to receive Backup transport errors:

    Code:
    Unable to send “/backup/2018-05-11/accounts/site1.tar.gz” to destination “host”
    Unable to send “/backup/2018-05-11/accounts/site2.tar.gz” to destination “host”
    Unable to send “/backup/2018-05-11/accounts/.master.meta” to destination “host”
    Unable to prune transport “host”
    Unable to remove outdated backup: Token refresh failed at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/OAuth/Cmdline.pm line 83
    Navigating to WHM Home »Backup »Backup Configuration I tired to edit the backup and refresh the secret code (via google API), however, the box to do so was grayed out. Unable to get anywhere I deleted that backup and tried to add a new one. Now when I add the new backup, I receive the following error during validation:
    Code:
    Error: Validation for transport “host” failed: Could not create path directory “/host/”: Cache file /var/cpanel/backups/928365448683-24uh684o1h4s1h7citb6fn65vp9ca7bc.apps.googleusercontent.com.yml not found. See GETTING STARTED in the docs for how to get started. at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/OAuth/Cmdline.pm line 191
    Also, via google when the popup appears I get the following error:
    Code:
    Google returned with the following error:  500 Can't connect to accounts.google.com:443 (No route to host) - Can't connect to accounts.google.com:443 (No route to host)
    
    LWP::Protocol::https::Socket: connect: No route to host at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/LWP/Protocol/http.pm line 46.
    
    Where do I go from here?
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Dezdan

    If you recreate the destination do you continue to get the same error? My Google Drive backup destination isn't experiencing this issue but I did find that I could create a separate one and it was successfully validated. In case you need the knowledgebase article on how to set this up again it's located here: Google Drive - cPanel Knowledge Base - cPanel Documentation

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi @cPanelLauren

    Yes, even in recreating the destination I am still receiving the same errors. I deleted the backup configuration on my server, and then I went to the Google API and deleted the credentials specific to the backup. I started all over, creating new Google API credentials and then creating a new backup destination on my server and are still receiving the following errors.

    When I click Generate Credentials to generate the credentials file and the new tab appears that allows me to authorize access to my Google Drive data, I get the following error after I click the Allow button:
    Code:
    Google returned with the following error:  500 Can't connect to accounts.google.com:443 (No route to host) - Can't connect to accounts.google.com:443 (No route to host)
    
    LWP::Protocol::https::Socket: connect: No route to host at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/LWP/Protocol/http.pm line 46.
    And then on WHM Home »Backup »Backup Configuration, I receive:
    Code:
    Error: Validation for transport “Host” failed: Could not create path directory “/host/”: Cache file /var/cpanel/backups/928365448683-9sp9kkv2972sbotq0fbvucq4rm5f3k9v.apps.googleusercontent.com.yml not found. See GETTING STARTED in the docs for how to get started. at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/OAuth/Cmdline.pm line 191
    Additionally, even when I created the new backup destination and new API, I see the following before I validate:
    CPanelBackupText.jpg
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Dezdan

    In that final screenshot it shows that maybe the credentials already exist (for the old google backup destination)

    They're stored in /var/cpanel/backups/ you might want to remove any references to them there first then recreate.

    I do feel like this is more to do with being unable to reach google though. I assume this was set up prior to updating, are you by chance using IPv6 at all on the server?


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hey @cPanelLauren,

    No change.

    No IPv6, and it was working fine prior to the most recent update. For background, you had helped me last month with an IPv6 issue: Google Validation for Transport Error

    Currently:
    IPv6.jpg
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    I remember that!

    At this point I don't think it's the same error, It seems for some reason your server is no longer able to reach google over 443 which is odd. Can you go ahead and open a ticket using the link in my signature? Once it's open please add the ticket ID here so that we can update this thread with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Thanks for the help.

    My Support Request ID is: 9560881
     
  8. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Thanks @Dezdan I'll update again once I have more information
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Sadly, the my support ticket has been of no help thus far. The first individual to help told me there was no issues and I was just doing it wrong. The second individual confirmed there was an issue, then told me that a common issue is IPv6 and I should disable it; then provided a link to my own previous topic on this help forum.
     
  10. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    HI @Dezdan

    I'm sorry to hear that, we're having one of our L2 analysts take another look at the ticket right now, he should be in contact with you soon.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Thank you @cPanelLauren!

    That was a weird one, IPv6 would not disable! Final cure to disable IPv6:

    Add:
    net.ipv6.conf.all.disable_ipv6 = 1

    To:
    /etc/sysctl.conf

    Run:
    sysctl -p

    Reboot to confirm.
     
  12. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Dezdan

    I'm really happy to hear that we were able to help get it sorted. All is working with the backup transport now then, right?


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice