Google Validation for Transport Error

Dezdan

Active Member
Jan 28, 2013
29
1
53
cPanel Access Level
Root Administrator
Two days ago I started receiving the following error message:

"Error: Validation for transport “accountname” failed: Could not create path directory “/accountname/”: Token refresh failed at /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/OAuth/Cmdline.pm line 83"

I went to Google API and updated my Client secret just to be sure something hadn't transpired, and that was of no help as when I go to "Generate Credentials", I allow via google and then I get the following error message:

"Google returned with the following error: 500 Can't connect to accounts.google.com:443 (No route to host) - Can't connect to accounts.google.com:443 (No route to host)

LWP::Protocol::https::Socket: connect: No route to host at /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/LWP/Protocol/http.pm line 46."

Everything was working fine prior, any ideas?
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,286
313
Houston
Hi @Dezdan

This issue looks specific to a connectivity issue with google drive, in a lot of instances I've seen this as an issue with IPv6. If IPv6 is configured on your server can you please disable it and let me know if the issue persists?

To disable IPv6 from your server, I recommend the following steps:

1. WHM 'Home >> IP Functions >> Assign IPv6 Address' (Assign IPv6 Address - Version 66 Documentation - cPanel Documentation) - ensure that IPv6 is disabled for every individual account on the server

2. WHM 'Home >> IP Functions >> IPv6 Ranges' (IPv6 Ranges - Version 66 Documentation - cPanel Documentation) - remove all IPv6 ranges from the server

3. Follow the instructions in the following link to disable IPv6 from the server: Guide to IPv6 - IPv6 Server Administration - Version 68 Documentation - cPanel Documentation

=====
To disable IPv6 on your server, run the following command: echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
=====

Thank you,
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,286
313
Houston
Hi @Dezdan

The only reason I can think of that it would remain greyed out is if there was still accounts that had it enabled. Can you confirm that all accounts have IPv6 disabled? You can see this at WHM>>IP Functions>>Assign IPv6 Address accounts with it enabled will have ENABLED in bold next to the account
 

Dezdan

Active Member
Jan 28, 2013
29
1
53
cPanel Access Level
Root Administrator
Nope, it did not work:
Code:
Error: Validation for transport “hostname” failed: Could not create path directory “/hostname/”: Token refresh failed at /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/OAuth/Cmdline.pm line 83
Also, now when I try to reach WHM>>IP Functions>>Assign IPv6 Address I get the following error on a blank pink screen:
Code:
A fatal error or timeout occurred while processing this directive.
The system could not find the <abbr title="Classless Inter-Domain Routing" class="initialism">CIDR</abbr> for the entered address: [MyIPv6Address]. at /usr/local/cpanel/Cpanel/IPv6/Utils.pm line 658.
 at /usr/local/cpanel/Cpanel/IPv6/Utils.pm line 658.
   Cpanel::IPv6::Utils::load_range_config() called at /usr/local/cpanel/Cpanel/IPv6/ApiSupport.pm line 550
   Cpanel::IPv6::ApiSupport::ipv6_range_list() called at whostmgr/bin/whostmgr2.pl line 9786
   main::enableipv6() called at whostmgr/bin/whostmgr2.pl line 1199
And at WHM Home >> IP Functions >> IPv6 Ranges I get:
Code:
API failure: The system could not find the CIDR (Classless Inter-Domain Routing) for the entered address: [MyIPv6Address]. at /usr/local/cpanel/Cpanel/IPv6/Utils.pm line 658.
What can I do to reverse that command?
 
Last edited:

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,286
313
Houston
hi @Dezdan

You can reverse disabling IPv6 by running:

Code:
echo 0 > /proc/sys/net/ipv6/conf/all/disable_ipv6
For the issue with the google drive backups, I would suggest opening a ticket to determine why you're not able to remove the IPv6 range which I believe is the cause of the issue.

Thank you,
 

Dezdan

Active Member
Jan 28, 2013
29
1
53
cPanel Access Level
Root Administrator
hi @Dezdan

You can reverse disabling IPv6 by running:

Code:
echo 0 > /proc/sys/net/ipv6/conf/all/disable_ipv6
I should have known that! Unfortunately, the same errors above are still present after enabling IPv6 and I am unable to access WHM>>IP Functions>>Assign IPv6 and WHM Home >> IP Functions >> IPv6 Ranges.

For the issue with the google drive backups, I would suggest opening a ticket to determine why you're not able to remove the IPv6 range which I believe is the cause of the issue.
Thank you, I will do that!
 

Dezdan

Active Member
Jan 28, 2013
29
1
53
cPanel Access Level
Root Administrator
My Support Request ID is: 9467903
Edit, they split the tickets, second is: 9467985
Thank you!
 
Last edited by a moderator:

Dezdan

Active Member
Jan 28, 2013
29
1
53
cPanel Access Level
Root Administrator
Problem solved! Interesting in that the IPv6 address has been there since Nov 2017 and it is the address that my host provided me.
"The issue was an invalid IPv6 address configured in WHM -> Basic WebHost Manager® Setup. The value input into the "The IPv6 address (only one address) to use to set up shared IPv6 virtual hosts." field needs to be valid IPv6 address which is routed and setup on this server. The previous value (my IPv6) is not an IPv6 address on this server currently."

On the google transport issue, a simple refresh of the token fixed the issue (which I had previously tried to no avail).
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,286
313
Houston
Hello @Dezdan

My assumption here was that the IPv6 address was invalid and as such it prohibits the connection to the Google backup drive. I'm glad they were able to resolve the issue for you and you're able to connect to your backups now!


Thank you,