Lucas Rodrigues

Registered
Dec 11, 2014
3
0
1
cPanel Access Level
Website Owner
Hi, I'm new at cPanel Forum, but I use cPanel for a long time and I never see that problem!

I buy a new server, but the HTTPD/Apache restart every midnight and crash!

In the log, I can see "Graceful restart requested, doing restart", every day at the same time.

In Google, and on cPanel forum I found some possible solutions:

- Enable Piped Log
- Disable Bandwidth Statistics
- Disable Log Rotation

What I do:
- Enable Piped Log.
- Deselect "Bandwidth Stats" at "Feature Manager"
- Set "Log Processing Frequency" to 720 hours at "Server Configuration"
- Set "Bandwidth Processing Frequency" to 720 hours, but give a error "Error: Bandwidth processing must be at least once per day."
- Select "all hours" on "Configure Statistic Process Time Schedule"
- Deselect "error_log" at "cPanel Log Rotation Configuration"

The problem persists!

How I can disable the Bandwidth and Log Rotation? How I can stop the Apache Restart?!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
Hello :)

Please see the following post regarding graceful restarts:

Apache Performing Graceful Restarts

Before you disable bandwidth and statistics, could you elaborate on what types of issues the graceful restarts are causing? Do you actually notice any failed attempts to access a website?

Thank you.
 

Lucas Rodrigues

Registered
Dec 11, 2014
3
0
1
cPanel Access Level
Website Owner
The server restart at 00:03, every day!

I know, if I change the httpd.conf the server need to be restarted. But, I use the SSH to make changes on httpd.conf and restart too.

But, everyday, at 00:03 the server is down. Is impossible enter on website, because the restart take 30 minutes or more! I need to enter in SSH and 'pkill -9 httpd' and after 'service httpd start', it is the one way to get my website online!


I think I have two ways to resolve that!
One is create one cron job! Every day at 00:04 do the 'pkill -9 httpd' and after 'service httpd start'. Because the cPanel can't disable the bandwith. ¬¬
And another way is stop use cPanel!

How I can disable the bandwith?!
Before I change the bandwith, to 24 hours, the server restart every 2 hours!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
But, everyday, at 00:03 the server is down. Is impossible enter on website, because the restart take 30 minutes or more!
It's not normal for a graceful restart of Apache to take that long. Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

Lucas Rodrigues

Registered
Dec 11, 2014
3
0
1
cPanel Access Level
Website Owner
Sorry, but I need only the way to disable the "bandwith", because if I set bandwith to 2 hours, the server is down every 2 hours. How I can disable?

- - - Updated - - -

The ticket is 5819139
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
The following thread should be helpful if you need to disable bandwidth reporting while the ticket is investigated:

Disable Bandwidth Reporting

Please ensure you update the support ticket to let them know you completed this action.

Thank you.