The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grant Create View and/or DB Not Showing in CP

Discussion in 'Database Discussions' started by zabberwan, Jan 20, 2011.

  1. zabberwan

    zabberwan Member

    Joined:
    Sep 16, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello Folks,

    I am just a CPanel user on a web hosting service with a normal run of the mill account - "unlimited" Space, Bandwidth, Databases, Domains, eMails etc. Except for a couple of vital things everything is fine.

    I have or more appropriately am in the process of developing, a small dynamic database driven site. The database is a small one containing 8 tables - 5 normal tables and 3 views with no data in them, but containing only the stand-in data for these. I am unable to update the database as it drops the Stand-in data of the view/s during that process and causes other corruption which does not let me even view the site. Now, this can be fixed by letting your host grant you the permission to do this which looks like this: "GRANT CREATE VIEW ON "DatabaseName".* TO `DatabaseUser`@`% ".

    In the first place almost all web hosting providers are paranoid about granting this command fearing as if their customer is going to vanish with their server and business or whatever. Thus, they simply undermine their customer's right to access the customer owned database.

    My old web hosting provider(WHP) eventually after a lot of persuasion allowed it, but it was not functioning and they didn't or couldn't say why. I changed that server for a new one and after some long wheeling and dealing with them they saw reason and consented to allow it. It worked as expected without a hitch.

    On the other hand I was now after transferring my databases to PHPMyAdmin, not able to see the databases in CPanel in "MySQL Databases" and couldn't create one with the same name as already existing in PHPMyAdmin and as a result couldn't assign users to them. So nothing was working anymore. So I appended the problem to old ticket. This was sent to management as the support probably had problems fixing it. Eventually they fixed that problem 3 days back, but find now that I can't update the database.

    They informed me today that they may have to revoke the permission they granted, but they did not mention any alternative solution. So, I am back up the creek without a paddle.

    Since you guys know the works inside and out, WHAT IS THE SOLUTION? I would really appreciate your opinion on this and possible resolutions. Are these two issue connected to each other and is it an "either/or" situation? I have nothing against the WHP, but I do need some kind of a solution amicable to both the customer as well as the web hosting provider, so that as a customer, I can access my own databases.

    Thanking you for your "views"!

    zabberwan
     
  2. zabberwan

    zabberwan Member

    Joined:
    Sep 16, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Quick note to inform you that everything's working smoothly as of now. The GRANT CREATE VIEW is in place and the other issue was caused during updating of CPanel.

    Thank you anyways and if you care to answer that, may be it will help someone else with a similar issues!

    zabberwan :)
     
Loading...

Share This Page