Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Greyed out RBL options in Exim Configuration Editor

Discussion in 'E-mail Discussion' started by thobarn, Dec 21, 2010.

  1. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    152
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    sanctum sanctorum
    Since updating to version WHM 11.28.52 RBL options under Main >> Service Configuration >> Exim Configuration Editor >> RBLs are greyed out.

    [​IMG]
     

    Attached Files:

    #1 thobarn, Dec 21, 2010
    Last edited: Dec 21, 2010
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,554
    Likes Received:
    9
    Trophy Points:
    168
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please provide output from the following command (via root SSH access):
    Code:
    # egrep "^acl_spam(cop|haus(_spamcop)?)_rbl=" /etc/exim.conf.localopts
    I believe the symptom displayed by your screenshot may occur if all three settings were enabled somehow, as seen below:
    Code:
    # egrep "^acl_spam(cop|haus(_spamcop)?)_rbl=" /etc/exim.conf.localopts
    acl_spamcop_rbl=1
    acl_spamhaus_rbl=1
    acl_spamhaus_spamcop_rbl=1
    To fix the problem, please try one of the following solutions:
    • Change "acl_spamhaus_spamcop_rbl=1" to "acl_spamhaus_spamcop_rbl=0" in "/etc/exim.conf.localopts".
    • Change "acl_spamcop_rbl=1" and "acl_spamhaus_rbl=1" from "=1" to "=0" in "/etc/exim.conf.localopts".
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    152
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    sanctum sanctorum
    Thanks, already solved it as you described. Yes, all three were set to one. And here is a method to get into that state from the UI.

    Main >> Service Configuration >> Exim Configuration Editor >>RBLs

    Defaults:
    RBL: bl.spamcop.net -> Off
    RBL: zen.spamhaus.org -> Off
    RBL: zen.spamhaus.org and bl.spamcop.net -> Off

    Steps to lock RBLs options:
    Select RBL: bl.spamcop.net -> On
    Select RBL: zen.spamhaus.org -> On
    Save config

    Each ON should grey out all of the remaining options if accidental locking to be prevented.
     
    #3 thobarn, Jan 11, 2011
    Last edited: Jan 12, 2011
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice