The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gtk2 Updated?

Discussion in 'General Discussion' started by alphawolf50, Dec 16, 2011.

  1. alphawolf50

    alphawolf50 Well-Known Member

    Joined:
    Apr 28, 2011
    Messages:
    186
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    My server runs 64-bit CentOS 5.7. I noticed in my logs that gtk2 was recently updated... I've always associated this package with graphical desktops, and couldn't think of any reason it would be on a cPanel server. Looking around, these packeages seem to be dependent upon gtk2:
    Code:
    # rpm -q --whatrequires gtk2
    libwnck-2.16.0-4.fc6
    poppler-0.5.4-4.4.el5_6.17
    libgcj-4.1.2-51.el5
    libgcj-4.1.2-51.el5
    
    That list was actually a bit short, so I also did "yum remove gtk2" and said "no" at the end to see this list:
    Code:
    Removing:
     gtk2                                        i386                           2.10.4-21.el5_7.7                           installed                          19 M
     gtk2                                        x86_64                         2.10.4-21.el5_7.7                           installed                          19 M
    Removing for dependencies:
     GConf2                                      x86_64                         2.14.0-9.el5                                installed                         4.7 M
     ecryptfs-utils                              i386                           75-5.el5_7.2                                installed                         387 k
     ecryptfs-utils                              x86_64                         75-5.el5_7.2                                installed                         462 k
     libgcj                                      i386                           4.1.2-51.el5                                installed                          40 M
     libgcj                                      x86_64                         4.1.2-51.el5                                installed                          53 M
     libnotify                                   x86_64                         0.4.2-6.el5                                 installed                          95 k
     libwnck                                     x86_64                         2.16.0-4.fc6                                installed                         523 k
     notification-daemon                         x86_64                         0.3.5-9.el5                                 installed                         111 k
     poppler                                     x86_64                         0.5.4-4.4.el5_6.17                          installed                         8.6 M
     poppler-utils                               x86_64                         0.5.4-4.4.el5_6.17                          installed                         163 k
     trousers                                    i386                           0.3.1-4.el5                                 installed                         793 k
     trousers                                    x86_64                         0.3.1-4.el5                                 installed                         780 k
    
    I did an "rpm -qi" on each of the packages, and they all seem to be related to a graphical desktop. Does anyone know if cPanel depends on any of these somehow? I did the minimal install, so I can't think of any way they got installed unless CentOS or cPanel requires them. Searching the forums leads me to unrelated (I think) threads about PEAR and cPanel PRO Plugin. Anyway, are these safe to remove?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
  3. alphawolf50

    alphawolf50 Well-Known Member

    Joined:
    Apr 28, 2011
    Messages:
    186
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hi Tristan,

    Thanks for replying. bluez-utils is not currently installed, but there's a good chance I removed it sometime after install if I found it. Evidence of this is that when I do a "rpm -qa | more", I found bluez-libs listed. It seems a safe assumption that bluez-utils would be dependent upon bluez-libs.

    .. After a little more digging, now I see that libX11 is installed as well. It does seem that the bug you linked is indeed the issue, and I've got a a bunch of crud installed that I should not.

    Can you confirm that it is safe to remove libX11? It will remove gtk2 as well, since gtk depends on it.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I prefer not to recommend removing anything other than gnome, which I know for a fact is not necessary on any hosting machine, since I do not know if you have anything that might depend on x11 for some reason. It seems unlikely the machine would need x11, but the decision to remove it will have to be up to you.
     
Loading...

Share This Page