Benjamin D.

Well-Known Member
Jan 28, 2016
151
23
68
Canada
cPanel Access Level
Root Administrator
In WHM v100.0.5 click Manage Plugins, get a BLANK page (no menu, no header) with just a pink error message box in the left corner. Guess we can't manage plugins with that WHM release, can we?

1.PNG

2.PNG
3.jpg
 

quietFinn

Well-Known Member
Feb 4, 2006
1,653
329
438
Finland
cPanel Access Level
Root Administrator
We can, works in all servers, version 100.0.5.
I'd suggest you run /scripts/upcp --force
 
  • Like
Reactions: cPanelAnthony

Benjamin D.

Well-Known Member
Jan 28, 2016
151
23
68
Canada
cPanel Access Level
Root Administrator
Been staring at this screen without any progress for a little over 5 minutes. Any ideas? I know there were lots of weirdness with Comodo SSL certificates lately, could it be related? Is it timing out on downloading cPanel updates files because of the semi-broken SSL certificate service?

dassasd.PNG


EDIT: After waiting 10 minutes, I got this, any idea?

progress.PNG


The blocker error states that the server needs at least OpenSSL 1.0.2e (2015) to continue. But the server already has 1.0.2k (2017) installed and running!

[[email protected] ~]# openssl version -a
OpenSSL 1.0.2k-fips 26 Jan 2017
built on: reproducible build, date unspecified
platform: linux-x86_64

[[email protected] ~]# rpm -qa | grep openssl
alt-openssl-1.0.2k-2.el7.cloudlinux.10.x86_64
cpanel-perl-532-crypt-openssl-rsa-0.31-1.cp1198.x86_64
openssl-1.0.2k-21.el7_9.x86_64
alt-openssl11-libs-1.1.1d-2.el7.x86_64
cpanel-perl-532-crypt-openssl-x509-1.813-1.cp1198.x86_64
ea-openssl11-1.1.1k-1.1.1.cpanel.x86_64
openssl-libs-1.0.2k-21.el7_9.x86_64
cpanel-perl-532-crypt-openssl-pkcs10-0.16-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-pkcs12-1.3-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-ec-1.32-1.cp1198.x86_64
openssl-devel-1.0.2k-21.el7_9.x86_64
alt-openssl11-1.1.1d-2.el7.x86_64
alt-openssl-libs-1.0.2k-2.el7.cloudlinux.10.x86_64
cpanel-perl-532-crypt-openssl-dsa-0.19-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-random-0.15-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-bignum-0.09-1.cp1198.x86_64
ea-openssl-1.0.2u-1.1.5.cpanel.x86_64
 
Last edited:

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
1,045
111
118
Houston, TX
cPanel Access Level
Root Administrator
Been staring at this screen without any progress for a little over 5 minutes. Any ideas? I know there were lots of weirdness with Comodo SSL certificates lately, could it be related? Is it timing out on downloading cPanel updates files because of the semi-broken SSL certificate service?

View attachment 75217


EDIT: After waiting 10 minutes, I got this, any idea?

View attachment 75221


The blocker error states that the server needs at least OpenSSL 1.0.2e (2015) to continue. But the server already has 1.0.2k (2017) installed and running!

[[email protected] ~]# openssl version -a
OpenSSL 1.0.2k-fips 26 Jan 2017
built on: reproducible build, date unspecified
platform: linux-x86_64

[[email protected] ~]# rpm -qa | grep openssl
alt-openssl-1.0.2k-2.el7.cloudlinux.10.x86_64
cpanel-perl-532-crypt-openssl-rsa-0.31-1.cp1198.x86_64
openssl-1.0.2k-21.el7_9.x86_64
alt-openssl11-libs-1.1.1d-2.el7.x86_64
cpanel-perl-532-crypt-openssl-x509-1.813-1.cp1198.x86_64
ea-openssl11-1.1.1k-1.1.1.cpanel.x86_64
openssl-libs-1.0.2k-21.el7_9.x86_64
cpanel-perl-532-crypt-openssl-pkcs10-0.16-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-pkcs12-1.3-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-ec-1.32-1.cp1198.x86_64
openssl-devel-1.0.2k-21.el7_9.x86_64
alt-openssl11-1.1.1d-2.el7.x86_64
alt-openssl-libs-1.0.2k-2.el7.cloudlinux.10.x86_64
cpanel-perl-532-crypt-openssl-dsa-0.19-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-random-0.15-1.cp1198.x86_64
cpanel-perl-532-crypt-openssl-bignum-0.09-1.cp1198.x86_64
ea-openssl-1.0.2u-1.1.5.cpanel.x86_64
Could you open a ticket per my previous response so we can investigate?