The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Has anyone gotten Java Servlets to work?

Discussion in 'General Discussion' started by jsteel, Jul 5, 2002.

  1. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    I've yet to be able to get servlets to work using the Tomcat install through CPanel. JSPs work fine, but every servlet returns a 404 Error ( 'The requested resource (/servlets/MyServlet) is not available').

    Has anyone had any success? What did you do if so?

    Thanks.
     
  2. Maximiliam

    Maximiliam Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    They work great, the only thing i cant get to work is the mapping feature.

    Under your public_html, create a WEB-INF, upload your servlets in there, create a web.xml and configure it.

    Then restart Tomcat.

    And you will be able to access your servlets with the virtual mapping domain.com/servlet/
     
  3. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    I need to get mapping and auto-reloading working like in JServ. I don't want to have to keep restarting Tomcat everytime someone wants to add a servlet. Anbody?
     
  4. Maximiliam

    Maximiliam Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Thats the pain you have to go thru, unfortunately..

    I would like a better system as well..
     
Loading...

Share This Page