The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Has anyone seen this error before

Discussion in 'General Discussion' started by flukebuzzsaw, Jun 23, 2005.

  1. flukebuzzsaw

    flukebuzzsaw Member

    Joined:
    Jun 10, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Warning: mysql_connect(): User *******has already more than 'max_user_connections' active connections in ../database.php on line 6
    Unable to connect!
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    This error means that a script requires persistent and high number of sql connections. OSCommerce and some other Php applications are very well known to produce/cause such a problem. You'll need to do the following: restart the MySQL service to clear out the connections, disable the application and/or increase the number of connections in the conf file. For example, in OSCommerce config file change from true to false:

    before
    define('USE_PCONNECT', 'true');
    after
    define('USE_PCONNECT', 'false');

    If you're dealing with a different application, just see if you can modify the "connection" in the conf file.
     
Loading...

Share This Page