Has anyone successfully installed mod_layout?

Valetia

Well-Known Member
Jun 20, 2002
216
10
168
cPanel Access Level
Root Administrator
I've done a search in the forums and found a procedure but it didn't work for me.

Can someone provide a step-by-step guide?
 

Tox

Member
Aug 12, 2002
16
0
151
Yes I use it on a server. It is used for a free webhosting service at www.gamhosting.com. You can signup for an account to see how it works although it just places a banner on top of all pages.

I have had a few problems when users included files in PHP but it can be fixed within the PHP code.
 

Valetia

Well-Known Member
Jun 20, 2002
216
10
168
cPanel Access Level
Root Administrator
Originally posted by Tox
Yes I use it on a server. It is used for a free webhosting service at www.gamhosting.com. You can signup for an account to see how it works although it just places a banner on top of all pages.

I have had a few problems when users included files in PHP but it can be fixed within the PHP code.
Tox your site looks great!

Did you install mod_layout using the same RPM link mentioned above (http://software.tangent.org/download/mod_layout-3.2-1.i386.rpm)?

Did it work right after that or did you have to do anything else? :)
 

danielaugustus

Well-Known Member
Oct 15, 2003
92
0
156
I'm trying to install it but I always get this message :

error: Failed dependencies:
apache >= 1.3.19 is needed by mod_layout-3.2.1-1

I updated Apache using the easyapache script. Does it has anything to do with this ?



Then, I tried the --nodeps option. But it didnt worked. Apache doesnt recognize the mod_layout commands.
 
Last edited:

casey

Well-Known Member
Jan 17, 2003
2,288
0
191
Originally posted by danielaugustus
I'm trying to install it but I always get this message :

error: Failed dependencies:
apache >= 1.3.19 is needed by mod_layout-3.2.1-1

I updated Apache using the easyapache script. Does it has anything to do with this ?
You've got a later version of apache (1.3.29) if there's a newer mod_layout you should install it instead.
 

danielaugustus

Well-Known Member
Oct 15, 2003
92
0
156
The deps says I need an Apache higher than 1.3.19. And I DO have ( 1.3.29 ) . Why it's giving this error ?

1.3.29 didnt changed the API for the mod_layout needs changed code from 1.3.28.

I simply cant understand.
 

danielaugustus

Well-Known Member
Oct 15, 2003
92
0
156
Well, I got a already compiled mod_layout.so module.

I loaded it using apache. But when I try to use LayoutHeader it says he doesnt recognize that.

I read someplace that I need to use Ifmodule.. Can someboy confirm ?
 

danielaugustus

Well-Known Member
Oct 15, 2003
92
0
156
I did it. This is because I havent inserted the AddMoule tag.

Now the modules is loaded. But whnever I try to use it inside httpd.conf i get :

service httpd restart
/etc/init.d/httpd: line 192: 12546 Segmentation fault (core dumped) $HTTPD -t >/dev/null 2>&1
/etc/init.d/httpd restart: configuration broken, ignoring restart
/etc/init.d/httpd restart: (run 'apachectl configtest' for details)
 

Website Rob

Well-Known Member
Mar 23, 2002
1,501
1
318
Alberta, Canada
cPanel Access Level
Root Administrator
Although I'm not familiar with this mod,

/usr/local/apache/bin/httpd -t

will tell you what, if any, problems there are with your httpd.conf file.
 

danielaugustus

Well-Known Member
Oct 15, 2003
92
0
156
I did like you, except the fact I used complete path.

LayoutFooter /home/hostwise/www/marketing/bar.html


I used this tag...

Anything worng ?
 

mbarb

Member
Aug 14, 2001
23
0
301
I have never been able to get any of the 3.XX version to work on a cpanel server, just segfaults all the time. I use 2.11.14 and for the most part it works OK..
 

mike_r

Well-Known Member
Nov 26, 2002
45
0
156
Hello,

From where you can get version 2.11 ???

Now only latest versions which doesnt works on cpanel.