May 6, 2015
5
0
1
New York City
cPanel Access Level
Root Administrator
I have spent almost the last 24 hours trying to set up cPanel on my VPS for a trial before I purchase a license and it has been impossible. I tried calling but I have to be a customer. I tried creating a support ticket but I have to have it installed. I'm stuck so I turned to the Forum.

Anyways, I receive multiple errors: "Unable to Synchronize" and cancels on Centos 7 or "iContact Broken Pipe" and hangs on Centos 6. Both were minimal running on a KVM virtual server.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello,

It's important to keep in mind that CentOS 7 is only supported with cPanel version 11.50. Version 11.50 is only available on the "Edge" build tier right now, so it's not ready for production machines (it's scheduled to move to the Current tier on May 11th, 2015). Could you elaborate on the full error message you receive when installing cPanel on a fresh installation of CentOS 6?

Thank you.
 
May 6, 2015
5
0
1
New York City
cPanel Access Level
Root Administrator
Hello,

It's important to keep in mind that CentOS 7 is only supported with cPanel version 11.50. Version 11.50 is only available on the "Edge" build tier right now, so it's not ready for production machines (it's scheduled to move to the Current tier on May 11th, 2015). Could you elaborate on the full error message you receive when installing cPanel on a fresh installation of CentOS 6?

Thank you.
I apologize, I forgot to mention I was trying to install on the edge tier on Centos 7 and the release tier on Cents 6. I am going to run the installation again to copy and paste the error message.
 
May 6, 2015
5
0
1
New York City
cPanel Access Level
Root Administrator
[20150506.130957] All files Staged
[20150506.130957] Testing if the newly downloaded RPMS can be installed without conflict
[20150506.130957] Testing RPM transaction
[20150506.130957] error: Failed dependencies:
[20150506.130957] MySQL-client is needed by cpanel-php54-webmail-5.1.1-1.cp1142.noarch
[20150506.130957] MySQL-server is needed by cpanel-php54-webmail-5.1.1-1.cp1142.noarch
[20150506.130957] MySQL-client is needed by cpanel-php54-horde-5.1.4-1.cp1142.noarch
[20150506.130957] MySQL-server is needed by cpanel-php54-horde-5.1.4-1.cp1142.noarch
[20150506.130957] W Exit Code: 254
[20150506.130957] ***** FATAL: Test install failed: error: Failed dependencies:
[20150506.130957] MySQL-client is needed by cpanel-php54-webmail-5.1.1-1.cp1142.noarch
[20150506.130957] MySQL-server is needed by cpanel-php54-webmail-5.1.1-1.cp1142.noarch
[20150506.130957] MySQL-client is needed by cpanel-php54-horde-5.1.4-1.cp1142.noarch
[20150506.130957] MySQL-server is needed by cpanel-php54-horde-5.1.4-1.cp1142.noarch
[20150506.130957] The Administrator will be notified to review this output when this script completes
[20150506.130957] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
[20150506.130957] MySQL-client is needed by cpanel-php54-webmail-5.1.1-1.cp1142.noarch
[20150506.130957] MySQL-server is needed by cpanel-php54-webmail-5.1.1-1.cp1142.noarch
[20150506.130957] MySQL-client is needed by cpanel-php54-horde-5.1.4-1.cp1142.noarch
[20150506.130957] MySQL-server is needed by cpanel-php54-horde-5.1.4-1.cp1142.noarch
[20150506.130957] see http://go.cpanel.net/rpmcheckfailed for more information
[20150506.130957] The Administrator will be notified to review this output when this script completes
[20150506.130957] E Detected events which require user notification during updatenow. Will send iContact the log
info [updatenow] No such locale as 'en'
info [updatenow] upcp Notification => ___ via EMAIL [level => 1]
Cpanel::iContact: icontact /usr/sbin/sendmail is not executable by 0
info [updatenow] No such locale as 'en'
Cpanel::iContact: icontact broken pipe
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello,

It looks like the installer is unable to install the required RPMs. You can email cs[@]cpanel.net directly and they can send the request to our technical support department if you can't open the support ticket directly. Let us know the ticket number you are assigned and we can update this thread with the outcome.

Thank you.
 
May 6, 2015
5
0
1
New York City
cPanel Access Level
Root Administrator
I contacted them, they responded 4 hours later with my ticket information. Here is the Centos 7 error:
[2015-05-06 12:26:31 -0400] Running version '11.49.9999.120' of updatenow.
[2015-05-06 12:26:31 -0400] --force passed on command line. Upgrade will disregard update config settings.
[2015-05-06 12:26:31 -0400] Using mirror '69.72.212.11' for host 'httpupdate.cpanel.net'.
[2015-05-06 12:26:31 -0400] Target version set to '11.49.9999.120'
[2015-05-06 12:26:31 -0400] Initial cPanel installation detected as in progress.
[2015-05-06 12:26:31 -0400] Checking license
[2015-05-06 12:26:31 -0400] Installation in progress. Skipping license check.
info [updatenow] No such locale as 'en'
[2015-05-06 12:26:31 -0400] E Blocker found: cPanel & WHM cannot update due to insufficient disk space in the staging directory, '/data'. The system requires 3 GB to update; this directory only has 0.70 GB available. The system failed to find a new staging directory with enough space to update. You can either clear enough disk space or select a new staging directory with enough disk space at Update Preferences interface.
info [updatenow] No such locale as 'en'
info [updatenow] No such locale as 'en'
info [updatenow] upcp Notification => [email protected] via EMAIL [level => 1]
Cpanel::iContact: icontact /usr/sbin/sendmail is not executable by 0
info [updatenow] No such locale as 'en'
info [updatenow] No such locale as 'en'
[2015-05-06 12:26:31 -0400] E The install encountered a fatal error: exec(/usr/sbin/sendmail) failed: No such file or directory at /data/.cpanel__server_respondint_com__upcp_staging/scripts/updatenow.static-cpanelsync line 29194.
[2015-05-06 12:26:31 -0400] exec(/usr/sbin/sendmail) failed: No such file or directory at /data/.cpanel__server_respondint_com__upcp_staging/scripts/updatenow.static-cpanelsync line 29194.
[2015-05-06 12:26:31 -0400] The subprocess “/usr/sbin/sendmail” reported the “ENOENT” (2) error when it ended. at /data/.cpanel__server_respondint_com__upcp_staging/scripts/updatenow.static-cpanelsync line 3812.
exec(/usr/sbin/sendmail) failed: No such file or directory at /data/.cpanel__server_respondint_com__upcp_staging/scripts/updatenow.static-cpanelsync line 29194.
exec(/usr/sbin/sendmail) failed: No such file or directory at /data/.cpanel__server_respondint_com__upcp_staging/scripts/updatenow.static-cpanelsync line 29194.
The subprocess “/usr/sbin/sendmail” reported the “ENOENT” (2) error when it ended. at /data/.cpanel__server_respondint_com__upcp_staging/scripts/updatenow.static-cpanelsync line 3812.
2015-05-06 12:26:31 650 (DEBUG): The installation process detected a failed synchronization. The system will reattempt the synchronization with the updatenow.static file...
2015-05-06 12:26:31 656 (FATAL): The installation process was unable to synchronize cPanel & WHM. Verify that your network can connect to httpupdate.cpanel.net and rerun the installer.
Removing /root/installer.lock.
 

Infopro

Well-Known Member
May 20, 2003
17,113
511
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
[2015-05-06 12:26:31 -0400] E Blocker found: cPanel & WHM cannot update due to insufficient disk space in the staging directory, '/data'. The system requires 3 GB to update; this directory only has 0.70 GB available. The system failed to find a new staging directory with enough space to update. You can either clear enough disk space or select a new staging directory with enough disk space at Update Preferences interface.
The install docs might be useful here:
Installation Guide - Hardware Requirements - cPanel Documentation
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.