The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Headache Problem!!

Discussion in 'General Discussion' started by virtualreality, Mar 7, 2009.

  1. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    All my email accounts in cPanel can receive emails from outside, but can not send out my emails to the outside, These days I've tested trying to send out-bound emails, but every time there is a yellow-color-background word saying:

    "There was an error sending your message: authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]"

    And my emails can not send out every time. I have used these cPanel-created email accounts for years and there have been NO problems, but why this Incorrect authentication problem coming out since I upgraded my WHM and cPanel to the New Version 11.24.4-STABLE_33345? I have not touched EXIM matters.

    What may be the causes of the problem?

    How to solve this headache problem??

    Anyone's help?

    Thank you very much from my heart!

    David
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    When you go to the section called 'Exim Configuration Editor' in WHM, are there any alerts showing when the page opens? No? Good.
    Are you using RoundCube to send these mails or are you sending from your computer?
     
  3. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    When I go to 'Exim Configuration Editor' in WHM, I have not seen there are alerts showing when the page opens. Today I even reset All EXIM Configs to Defaults (Clicked the right button on the bottom of 'Exim Configuration Editor' in WHM. However, the problem still exists.

    I do not use "RoundCube" to send emails and not send emails from my computer.

    I don't favor RoundCube or Dovecot or some new email software for my emails. Still, I have used and continue using the traditional, reliable EXIM, Courier for my email. EXIM and Courier have been VERY STABLE for several years for me.

    The problem may be related to other things? Authentication failure??? What's this???

    I did enable SPF and DomainKeys in my cPanel, and since enabling SPF and DomainKeys in my cPanel, I have received and sent out emails smoothly, without problems, for several years!!!

    These days I tried to send emails within my cPanel-created, Horde-based email accounts, but all my emails can not send out! And every time after I clicked the "Send" bottom in my Horde-email accounts, I saw this:

    There was an error sending your message: authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]"

    What's wrong with the problem?

    Help please!
     
    #3 virtualreality, Mar 7, 2009
    Last edited by a moderator: Mar 8, 2009
  4. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    In WHM, I did do "Convert Accounts to Maildir" and WHM says "Maildir is already enabled on this system."

    Maybe the problem relates to this?
     
    #4 virtualreality, Mar 7, 2009
    Last edited by a moderator: Mar 8, 2009
  5. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Just now I have done Mail Troubleshooter in WHM, with one of my cPanel email accounts. It says:

    Legend
    Mail Routing Error
    Filter/Alias File
    SMTP Destination

    Why??

    How to solve??

    Thank you very much!!!
     
    #5 virtualreality, Mar 7, 2009
    Last edited by a moderator: Mar 8, 2009
  6. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Anyone here?

    Please help!
     
    #6 virtualreality, Mar 7, 2009
    Last edited by a moderator: Mar 8, 2009
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Not sure why you had to use all those colors, but people are put off by that, IMO.

    If you're in a hurry and aren't able to solve this problem, you might ask your host for advice, or try putting in a ticket with cPanel at this URL.

    https://tickets.cpanel.net/submit/?reqtype=tickets
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Try to check an email off the server. If you're checking an email on the server you get those results as it didn't have to go anywhere to check it.
     
  9. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Thanks to Infopro!

    However, the problem is still not fixed.

    I have checked the settings concerning mail within WHM and several cPanels. I've found all the settings look fine as usual. I have not changed all those setting.

    Do not know why suddenly all my cPanel email accounts can not send out-going emails. Why?

    Any more help please!

    David
     
  10. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Or this problem relates to /etc/ and /mail/ permissions?

    Or it relates to SMTP? However, I have checked to see SMTP is not down.
     
  11. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  12. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Thanks Infopro!
     
  13. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    What are the correct /etc/ and /mail/ permissions in cPanel???
     
  14. britsenigma

    britsenigma Well-Known Member

    Joined:
    Dec 14, 2008
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Permissions on those foders should be drwxr-xr-x

    aka

    755
     
  15. britsenigma

    britsenigma Well-Known Member

    Joined:
    Dec 14, 2008
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Login via SSH, these might help you track down the problem in realtime.

    tail -60000 /var/log/maillog

    or

    tail -f /var/log/maillog

    or

    tail -60000 /var/log/maillog | grep email@ddd

    Now, those are related to IMAP and POP3!!!!!!!!!!

    For SMTP use the following:

    tail -60000 /var/log/exim_mainlog

    or

    tail -f /var/log/exim_mainlog

    or

    tail -60000 /var/log/exim_mainlog | grep emailaccountinquestion@etc.com

    or

    tail -f /var/log/exim_mainlog | grep gemma@etc.com


    You can mix and match, grep is handy for isolating a specific entry, if a certain email address is failing, you can limit the logs with an email address, or an error code like 535.

    If you're running an unusual distribution of linux that has the logs elsewhere, you'll have to locate them and try those commands. You can use -f (follow) to watch what's happening in real time.
     
  16. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Thanks britsenigma for your help!

    The email authentication problem still exists. I have searched some related settings and they are normal as usual. I have not touched those settings for years and have smoothly used cPanel email functions for years.

    I'm going to follow your guide to check more about the problem.
     
  17. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    If you are trying to send via webmail it's a bug - change your webmail to use sendmail instead of smtp.
     
  18. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Thanks rs-freddo!

    Dude, what you say is what I'm considering, too! I think there is a BUG there in Horde or cPanel that has caused the problem (Can not send out-going emails), because I have not changed the WHM/cPanel settings and those same settings have let me send out cPanel-based emails for several years!
     
  19. virtualreality

    virtualreality Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Is there really a BUG in Horde or cPanel that can keep emails from sending out of webmail boxes??

    If yes, do you know something about the BUG in Horde or cPanel??

    Thanks!
     
Loading...

Share This Page