The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help 4.3.1 messed some sites need to downgrade to 4.2.3

Discussion in 'General Discussion' started by Speed, Feb 28, 2003.

  1. Speed

    Speed Member

    Joined:
    Dec 6, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I am lost i used /scripts/easyapache
    When I did installed php 4.3.1
    Now I have 5 sites that are not working

    This is the error
    Fatal error: Cannot redeclare unixdate() Fatal error: Cannot redeclare unixdate() in /home/casheze/public_html/pnadodb/adodb.inc.php on line 1477

    All the sites must be running the same script because all errors are the same.

    How do i downgrade php 4.3.1 back to php 4.2.3

    Any Help Please

    Thank you
     
  2. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    Is there an issue with going to the script in question on the line specified and commenting out the redeclare? That will make the error go away.
     
  3. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    Annette's solution is by far the best one. Just comment out that function declaration in the script. However, if you want to downgrade, you can do so with the easyapache script. I forget when option it is, but one of the options allows you to choose which version you want to run.
     
  4. kempes

    kempes Active Member

    Joined:
    Aug 20, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem. Some sites do not work anymore.

    Anyone has tried to downgrade their PHP to 4.2.3?
    Will you share your experience when you do /scripts/easyapache?

    Thanks.
     
  5. jimcarter

    jimcarter Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
  6. Pilgrim

    Pilgrim Active Member

    Joined:
    Apr 29, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I'm still interested in downgrading from 4.3.1 to a 4.2.x version. Is there a script available in /scripts or does it have to be done manually?

    Has anyone done it and what were your experiences?
     
  7. LS_Drew

    LS_Drew Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    16
    You guys are gonna have to upgrade sometime, as they're probably going to find some security hole that will force you to. It's been out for a while now. May as well ride it out and deal with it now rather than later. :)
     
  8. mesranet

    mesranet Well-Known Member

    Joined:
    May 6, 2002
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Hi all,

    Please try this:

    From the root, please run find /home/username/ -type f -iname '*.php' -exec perl -i -p -e 's/\"LC_TIME\"/LC_TIME/ig' {} \;

    Change the username to any username have a problem on php, it was problem on "LC_TIME"


    Thank you.
     
    #8 mesranet, Mar 29, 2003
    Last edited: Mar 29, 2003
Loading...

Share This Page