The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP: 500 Internal Server Error after Changing Owner:Group

Discussion in 'General Discussion' started by itsabhik, Nov 7, 2012.

  1. itsabhik

    itsabhik Registered

    Joined:
    Mar 1, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello,
    I changed (had to) the owner and group of the public_html folder (recursively) to account:nobody and now I am getting a 500 Internal Server Error.

    PHP runs under nobody:nobody as suphp

    Old Settings
    plublic_html folder: account:nobody
    Rest of the files and folder under it was account:account

    New Settings
    The public_html folder and all the files and folders under it is account:nobody

    This is the error I am getting in my error log:
    Code:
    [Thu Nov 08 00:53:27 2012] [error] [client 69.171.224.112] SoftException in Application.cpp:431: Mismatch between target GID (501) and GID (99) of file "/home/account/public_html/vbseo.php"
    What to do now?
    Thanks
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    That should be what you want, not your old settings. Recursively changing owner like this should not be done without some thought.
    What makes you say this? Have you read the docs?
    Apache PHP Request Handling - cPanel Documentation
     
  3. itsabhik

    itsabhik Registered

    Joined:
    Mar 1, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I really didn't get you on this. It's my old setting you quoted.

    I used this to find.
    Code:
    egrep -iw --color=auto '^user|^group' /etc/httpd/conf/httpd.conf
    Code:
    http://www.cyberciti.biz/faq/unix-osx-linux-find-apache-user/
    What am I doing wrong?
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sorry, those old settings, should be your current settings. Not your old settings, they are correct for SuPHP.
     
  5. itsabhik

    itsabhik Registered

    Joined:
    Mar 1, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    :((
    Shall I use account:nobody for CGI-FCGI PHP Handler or account:account for SuPHP PHP Handler?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    Well, you'd have had to be more clear here with exactly what you're going for. The documentation I linked you to should be helpful, you only need to read up on all this to understand it a bit better. Or, search these forums for one of the many, many threads on this topic.
     
Loading...

Share This Page