The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help. apache not restarting after buildapache.sea update

Discussion in 'EasyApache' started by carperman, Mar 23, 2002.

  1. carperman

    carperman Well-Known Member

    Joined:
    Feb 7, 2002
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    hello, i just done a buildapache.sea update but now get error when restarting apache:

    /etc/rc.d/init.d/httpd configtest
    [Sat Mar 23 15:20:58 2002] [warn] NameVirtualHost 66.96.214.245:80 has no VirtualHosts
    [Sat Mar 23 15:20:58 2002] [warn] NameVirtualHost 66.96.214.245:80 has no VirtualHosts


    really need help here
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    That is not a cataclysmic error by any stretch of the imagination. Apache is running and spawning processes, right?

    That error means you have designated a particular IP for name based virtual hosting at the top of your apache config- but in your virtual hosts sections you don't have a particular host configured to use that IP specifically.
     
  3. carperman

    carperman Well-Known Member

    Joined:
    Feb 7, 2002
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    err, yes i do.


    #
    # Use name-based virtual hosting.
    #
    NameVirtualHost 66.96.214.245:80


    later

    NameVirtualHost 66.96.214.245:80
    Alias /bandwidth/ /usr/local/bandmin/htdocs/




    &VirtualHost 66.96.214.246&
    ServerAdmin sysadmin@domain.net
    DocumentRoot /home/domain/public_html
    BytesLog domlogs/domain.net-bytes_log
    ServerName www.domain.net
    CustomLog domlogs/domain.net combined
    ScriptAlias /cgi-bin/ /home/domain/public_html/cgi-bin/
    &/VirtualHost&



    #NameVirtualHost 66.96.214.245:80
    &VirtualHost 66.96.214.245&
    ServerAlias www.domain2.co.uk domain2.co.uk
    ServerAdmin webmaster@domain2.co.uk
    DocumentRoot /home/domain2/public_html
    BytesLog domlogs/domain2.co.uk-bytes_log
    ServerName www.domain2.co.uk
    CustomLog domlogs/domain2.co.uk combined
    ScriptAlias /cgi-bin/ /home/domain2/public_html/cgi-bin/
    &/VirtualHost&


    of course above entires have been change to protect the innocent and are repeat many times.
     
  4. carperman

    carperman Well-Known Member

    Joined:
    Feb 7, 2002
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    ok i deleted my apache dir, after backing up, and reinstalled buildapache.sea.

    I commented out mod_perl and turned off suexec and all works ok except

    I cannot get into http://server-ip/bandwidth/
    to see bandmin results, which i could before.

    I have created a .htpasswrd and .htaccess in
    /usr/local/bandmin/htdocs
    which has entries

    AuthUserFile /usr/local/bandmin/htdocs/safe/.htpasswd
    AuthGroupFile /dev/null
    AuthName bandwidth
    AuthType Basic

    require user me
    ------

    but still not luck.


    also .htaccess entry for normal domains:

    DirectoryIndex index.php index.html index.htm

    does not work, it always shows index.html 1st.
     
Loading...

Share This Page