The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help, bind down, none of my sites load

Discussion in 'Bind / DNS / Nameserver Issues' started by AbeFroman, Jun 3, 2002.

  1. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    Hello,

    Bind has failed.

    When i try to restart bind i get the message....
    &Attempting to restart bind
    ndc: connect failed: connection refused bind status bind did not return a status report&

    How do i fix this?

    Thanks in advance for your help.
     
  2. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    help help help help help

    hi like 20% of the sites load and like 80% of the sites dont, how do i fix this and what causes it?

    thanks in advance
     
  3. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    cat /var/log/messages

    FTP login timed out, disconnected.
    Jun 2 14:28:52 server101 named: named shutdown failed
    Jun 2 14:28:53 server101 named: named shutdown failed
    Jun 2 14:28:53 server101 named-wrapper[6042]: starting BIND 9.2.0 -u named
    Jun 2 14:28:53 server101 named-wrapper[6042]: using 2 CPUs
    Jun 2 14:28:53 server101 named: named-wrapper startup succeeded
    Jun 2 14:28:53 server101 named-wrapper[6044]: loading configuration from '/etc/named.conf'
    Jun 2 14:28:53 server101 named-wrapper[6044]: /etc/named.conf:32: option 'allow-update' is not allowed in 'slave' zone 'localhost'
    Jun 2 14:28:53 server101 named-wrapper[6044]: loading configuration: failure
    Jun 2 14:28:53 server101 named-wrapper[6044]: exiting (due to fatal error)
    Jun 2 14:30:28 server101 sshd(pam_unix)[6091]: session opened for user root by (uid=0)
    root@server101 [~]#
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Fix the error it reported on line 32:

    Jun 2 14:28:53 server101 named-wrapper[6044]: /etc/named.conf:32: option 'allow-update' is not allowed in 'slave' zone 'localhost'



    Or remove it.
     
  5. avara

    avara Well-Known Member

    Joined:
    Oct 28, 2001
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    If you're getting the dreaded &ndc: connect failed: connection refused& error, try running the following from SSH:

    /scripts/fixndc
     
Loading...

Share This Page