The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! cpu load exceeding 100% causing server restart loop

Discussion in 'General Discussion' started by tomcraig, May 7, 2011.

  1. tomcraig

    tomcraig Registered

    Joined:
    May 7, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I really hope someone can help me here!

    I am running c-panel and WHM. The server has been fine until Thursday when it started behaving strangely.

    One of the sites on the server was having issues with the max_allowed_packet variable being set too low so I edited /etc/my.cnf to increase the sql variable max_allowed_packet from 1mb to 16mb.

    However, since around making this change one of the sites on the server keeps drawing heavily on the cpu's usage - exceeding 100% - which causes the server to reboot (it is stuck in a loop of rebooting).

    Does anyone have any suggestions on how to get the server back to normal? I can't get in to edit the file before the server resets at the moment. I've tried killing the site that is causing the cpu overload, but when I try to kill it says it doesn't exist.
     
  2. JerrySmith

    JerrySmith Active Member

    Joined:
    Apr 21, 2011
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    If you have physical access (or KVM), you can enter into single user mode with grub. This will allow you to revert the change, suspend the user, or anything else you need to do. Most datacenters will provide KVM at request. You may also be able to instruct them to log into single user and modify the file for you.

    Once you are done with single user mode, you can either reboot or type 'init 3' to fully boot the system, at your discretion.

    Barring single user mode, the only other way I know of to stop a reboot loop is by rescue shell or a live boot cd. Single user mode should be the easiest of them though.

    Please see this for instructions:

    Boot Linux Grub Into Single User Mode
     
  3. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    Shut down MYSQL then revert it to prior settings.
    After that you will need to do a MYSQL tune up to set the settings so it will not cause problems.

    But the user may have custom code that is causing your problem
    Bad SQL statements can cause very high loads.
     
Loading...

Share This Page