The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[help] error install perl module

Discussion in 'General Discussion' started by openpro, Feb 26, 2008.

  1. openpro

    openpro Registered

    Joined:
    Feb 26, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Attempting to install URI::URL

    spawn /scripts/perlinstaller URI::URL
    Method: Perl Expect
    Fetching CPAN timestamp...Done

    Testing connection speed...(this could take a while)...Done

    Ping:2.225 Testing connection speed to mirrors.24-7-solutions.net using pureperl...(156650.00 bytes/s)...Done

    Ping:4.850 Testing connection speed to mirrors.phenominet.com using pureperl...(156500.00 bytes/s)...Done

    Ping:1.393 Testing connection speed to mirror.datapipe.net using pureperl...(1702.16 bytes/s)...Done

    Three usable mirrors located

    Mirror Check passed for mirrors.24-7-solutions.net (/index.html)

    Unknown config variable 'less'

    commit: wrote '/usr/lib/perl5/5.8.8/CPAN/Config.pm'

    CPAN: File::HomeDir loaded ok (v0.69)

    CPAN: Storable loaded ok (v2.18)

    Going to read /home/.cpan/Metadata

    Database was generated on Mon, 25 Feb 2008 06:30:58 GMT

    URI::URL is up to date (5.03).

    perlmod--Install done



    Please help me..
     
  2. cPanelBilly

    cPanelBilly Guest

    This module is already installed
    Code:
    URI::URL is up to date (5.03).
    If you want to force a reinstall click the force button.
     
  3. openpro

    openpro Registered

    Joined:
    Feb 26, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    But when I try to install squid, still got error. Server said:

    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package squid.i386 7:2.6.STABLE6-5.el5_1.2 set to be updated
    --> Running transaction check
    --> Processing Dependency: perl(URI::URL) for package: squid
    --> Finished Dependency Resolution
    Error: Missing Dependency: perl(URI::URL) is needed by package squid
     
    #3 openpro, Feb 26, 2008
    Last edited: Feb 26, 2008
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    That's an entirely different issue. The squid RPM is looking for an RPM installed version of URI::URL, not a CPAN installed version. YOu'll need to either install the RPM version of URI::URL or somehow cause the sqid RPM to ignore the missing dependencies and install anyway.
     
  5. openpro

    openpro Registered

    Joined:
    Feb 26, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I know what is happen. Because cpanel was disable yum update for perl. So we can't upgrade dependencies. /etc/yum.conf
    I've disable those option, and work properly :D
     
  6. abs0lut3

    abs0lut3 Member

    Joined:
    Feb 14, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Oh, thank you.
    Got exactly same issue.
    Now removed "perl*" from yum.conf and squid was installed :)
     
  7. linux77

    linux77 Member

    Joined:
    Sep 6, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    This worked for me as well.

    Thanks!
     
Loading...

Share This Page