The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help - High 5 minute load average alerts 15.35

Discussion in 'General Discussion' started by fearmydesign, Feb 28, 2011.

  1. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    Hello everyone, I am having some slowness issues with my server and I have no idea why. I am getting many emails from the server with the following subject lines:

    High 5 minute load average alerts 15.35

    Email queue size alert (exim delivery queue size is 2207, the mailscanner pending queue is 170)

    Excessive resource usage: (951) - and several other numbers\

    Can anyone help me with any of these errors, I have no idea what to check... thank you
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    It means your server's load is too high - you're going to have to do some system admin work to figure out what is causing it :)

    I'd start with running 'top' and then going to WHM > Daily process log and looking for users with higher amounts of CPU. Unix process accounting is also a good tool to find high resource users. It's most likely that a site on your server is causing the problem.
     
  3. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    the thing is that there is currently one domain only, there are no other users on this server, it's a dedicated server. I did check the Mail Queue and there were over 2,000 emails on queue and I just went ahead and deleted them all... but it is still slow... I also found one email account that was past it's limit... could this have anything to do with it?

    Please help, thank you
     
  4. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    Ok, I also tried to force the Delivery of some emails and this is the message I got, any idea?

    exim: incompatible command-line options or arguments
     
  5. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    The email account past its quota could cause the mail queue buildup, but I doubt it's causing the load unless there's a ton of email going out. I can't really tell you what's going on with the server without seeing it, I can only give you recommendations on how to find it. 'top' (then hit P) should give you a general idea of what's going on.
     
  6. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    Yes, actually I deleted all these emails and it is faster now, it's not clugged... but when I try to send emails I get Return Mail Delivery failed with the following information, can you help me interpret this and figure it out please?
    _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

    /etc/exim_outgoing.conf@server1.artelye.com
    Unrouteable address
    -v@server1.artelye.com
    Unrouteable address
    -M@server1.artelye.com
    Unrouteable address
    1Pu6zP-00045N-2X@server1.artelye.com
    Unrouteable address
     
  7. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    That's sort of strange - make and edits to exim.conf lately? Try this:

    /scripts/eximup --force
     
  8. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    Ok, I did this and it's doing something.... is this updating the exim? it says Install Done, do I have to restart the server or anything like that? ...wait... it says Exim restarting... exim started ok, Install complete...

    ?
     
  9. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    Any idea why I have 95 emails still on ConfigServer Mail Queues and also showing under Mail Queue Manager

    When I go to Mail Queue Manager and try to click on Attemp to Deliver All Messages in Queue it spits out the following message and doesn't do anything, the emails are still there: exim: incompatible command-line options or arguments
     
  10. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    It basically updates Exim and reset the configuration file to defaults + options you chose in WHM. Are you still getting the same issue sending mail?
     
  11. fearmydesign

    fearmydesign Well-Known Member

    Joined:
    Aug 24, 2009
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    I tried sending an email and I didn't get anything back, so that may of fixed that issue. Thank you. Do you have any suggestions or ideas for the following below?

    Any idea why I have 95 emails still on ConfigServer Mail Queues and also showing under Mail Queue Manager

    When I go to Mail Queue Manager and try to click on Attemp to Deliver All Messages in Queue it spits out the following message and doesn't do anything, the emails are still there: exim: incompatible command-line options or arguments
     
  12. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    The emails may be formatted badly from when Exim was messed up so I'm not sure that they can be delivered. You can try looking at them to see if they are even emails you need.

    First, run 'exim -bp' which will spit out all the emails in the queue:

    Code:
    root@server1 [~]# exim -bp
     3d   832 1PsuAQ-0003Jy-5T <vasa@server1.xxx.com>
              sender@otherdomain.com

    Now check the message using the message ID:

    exim -Mvh 1PsuAQ-0003Jy-5T

    If you need to clear out the queue, the easy way to do it is by deleting /var/spool/exim/input (don't recreate the folder, exim will do that automatically). You can also try forcing the emails through the queue, but if they are malformatted you'll end up having to remove them:

    exim -bpru |awk '{print $3}' | xargs -n 1 -P 40 exim -v -M
     
Loading...

Share This Page