Help - High 5 minute load average alerts 15.35

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
Hello everyone, I am having some slowness issues with my server and I have no idea why. I am getting many emails from the server with the following subject lines:

High 5 minute load average alerts 15.35

Email queue size alert (exim delivery queue size is 2207, the mailscanner pending queue is 170)

Excessive resource usage: (951) - and several other numbers\

Can anyone help me with any of these errors, I have no idea what to check... thank you
 

vanessa

Well-Known Member
PartnerNOC
Sep 26, 2006
833
28
178
Virginia Beach, VA
cPanel Access Level
DataCenter Provider
It means your server's load is too high - you're going to have to do some system admin work to figure out what is causing it :)

I'd start with running 'top' and then going to WHM > Daily process log and looking for users with higher amounts of CPU. Unix process accounting is also a good tool to find high resource users. It's most likely that a site on your server is causing the problem.
 

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
I'd start with running 'top' and then going to WHM > Daily process log and looking for users with higher amounts of CPU. Unix process accounting is also a good tool to find high resource users. It's most likely that a site on your server is causing the problem.
the thing is that there is currently one domain only, there are no other users on this server, it's a dedicated server. I did check the Mail Queue and there were over 2,000 emails on queue and I just went ahead and deleted them all... but it is still slow... I also found one email account that was past it's limit... could this have anything to do with it?

Please help, thank you
 

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
Ok, I also tried to force the Delivery of some emails and this is the message I got, any idea?

exim: incompatible command-line options or arguments
 

vanessa

Well-Known Member
PartnerNOC
Sep 26, 2006
833
28
178
Virginia Beach, VA
cPanel Access Level
DataCenter Provider
The email account past its quota could cause the mail queue buildup, but I doubt it's causing the load unless there's a ton of email going out. I can't really tell you what's going on with the server without seeing it, I can only give you recommendations on how to find it. 'top' (then hit P) should give you a general idea of what's going on.
 

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
The email account past its quota could cause the mail queue buildup, but I doubt it's causing the load unless there's a ton of email going out. I can't really tell you what's going on with the server without seeing it, I can only give you recommendations on how to find it. 'top' (then hit P) should give you a general idea of what's going on.
Yes, actually I deleted all these emails and it is faster now, it's not clugged... but when I try to send emails I get Return Mail Delivery failed with the following information, can you help me interpret this and figure it out please?
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

/etc/[email protected]
Unrouteable address
[email protected]
Unrouteable address
[email protected]
Unrouteable address
[email protected]
Unrouteable address
 

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
That's sort of strange - make and edits to exim.conf lately? Try this:

/scripts/eximup --force
Ok, I did this and it's doing something.... is this updating the exim? it says Install Done, do I have to restart the server or anything like that? ...wait... it says Exim restarting... exim started ok, Install complete...

?
 

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
Any idea why I have 95 emails still on ConfigServer Mail Queues and also showing under Mail Queue Manager

When I go to Mail Queue Manager and try to click on Attemp to Deliver All Messages in Queue it spits out the following message and doesn't do anything, the emails are still there: exim: incompatible command-line options or arguments
 

fearmydesign

Well-Known Member
Aug 24, 2009
94
1
56
It basically updates Exim and reset the configuration file to defaults + options you chose in WHM. Are you still getting the same issue sending mail?
I tried sending an email and I didn't get anything back, so that may of fixed that issue. Thank you. Do you have any suggestions or ideas for the following below?

Any idea why I have 95 emails still on ConfigServer Mail Queues and also showing under Mail Queue Manager

When I go to Mail Queue Manager and try to click on Attemp to Deliver All Messages in Queue it spits out the following message and doesn't do anything, the emails are still there: exim: incompatible command-line options or arguments
 

vanessa

Well-Known Member
PartnerNOC
Sep 26, 2006
833
28
178
Virginia Beach, VA
cPanel Access Level
DataCenter Provider
The emails may be formatted badly from when Exim was messed up so I'm not sure that they can be delivered. You can try looking at them to see if they are even emails you need.

First, run 'exim -bp' which will spit out all the emails in the queue:

Code:
[email protected] [~]# exim -bp
 3d   832 1PsuAQ-0003Jy-5T <[email protected]>
          [email protected]

Now check the message using the message ID:

exim -Mvh 1PsuAQ-0003Jy-5T

If you need to clear out the queue, the easy way to do it is by deleting /var/spool/exim/input (don't recreate the folder, exim will do that automatically). You can also try forcing the emails through the queue, but if they are malformatted you'll end up having to remove them:

exim -bpru |awk '{print $3}' | xargs -n 1 -P 40 exim -v -M