Help I have been locked out by the brute force sistem.

novice07

Member
Mar 29, 2008
8
0
51
I can't log in in WHM, even from my server's keyboard. Cphulkd Brute force protection is preventing access to my WHM account. I can;t login , all I get is Brute force protection, this account is currentlu locked out....... wait 10 minutes and try again, I did wait for half an hour and I still get the same message. Since I can't login WHM I can't disable the brute force protection.

Even more this burte force sistem has locked me out from loging on to Linux.
I had to login in single mode and reset my password with the passwd command.
Each time I try to login in to WHM I get locked out of my server if I restart the machine and each time I have to reset the password or else I am not able to login to Linux. All this after I input the wrong password for a Cpanel account, it locked all the accounts on the server including the root account.

Is this normal ? How can I disable the brute force sistem from outside WHM.
 

raselaiub

Registered
Mar 31, 2009
4
0
51
Calgary, AB
Hi,

Yes, you are having this problem since the brute force protection is enabled in your server. You can disbale this following those steps: WHM >> Security >> Security Center >> cPHulk Brute Force Protection.


Good luck!
 

joand

Registered
Jul 6, 2003
2
0
151
Brute Force

I am having the same problem. The instructions you gave are for disabling it from within WHM. However the problem is that we cannot get into WHM due to the brute force protection.
 

thobarn

Well-Known Member
Apr 25, 2008
152
1
68
sanctum sanctorum
Hi

if you can still ssh to the server login as root and type the following at the prompt
Code:
mysql
prompt should change to mysql
Code:
mysql> use cphulkd;
you will see...database changed
Code:
mysql>BACKUP TABLE `brutes` TO '/path/to/backup/directory';
backup first!
Code:
mysql> SELECT * FROM `brutes` WHERE `IP`='xxx.xxx.xxx.xxx';
insert your IP instead xxx.xxx.xxx.xxx. Is your IP there? If so,
Code:
mysql> DELETE FROM `brutes` WHERE `IP`='xxx.xxx.xxx.xxx';
that should remove your IP from the table and you will see that in mysql reply. Finally
Code:
mysql>quit
should return you to your usual prompt. HTH

` symbols are backticks, Above Caps Lock and Tab keys on a uk-gb keyboard, in some setups you can omit them
' symbol is the usual single quote
remember ; symbol after each line before pressing enter when you are in mysql prompt
 
Last edited:

allpar

Well-Known Member
Sep 16, 2005
52
3
158
But it's great advice for those of us who DO have access to SSH via a second server or hosting account.
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
donn't worry

for security its recommended to keep enabled this protection.
Yes, you are having this problem since the brute force protection is enabled in your server. You can disbale this following those steps: WHM >> Security >> Security Center >> cPHulk Brute Force Protection.

just enter your IP address as Trusted Hosts List in brute force protection & you won't be blocked again.

i also have the same problem before 6th months & i did this after then i never blocked again by brute force
 
Last edited:

chandro

Well-Known Member
Nov 21, 2005
99
0
156
/home/chandro
cPanel Access Level
Root Administrator
Hi

if you can still ssh to the server login as root and type the following at the prompt
Code:
mysql
prompt should change to mysql
Code:
mysql> use cphulkd;
you will see...database changed
Code:
mysql>BACKUP TABLE `brutes` TO '/path/to/backup/directory';
backup first!
Code:
mysql> SELECT * FROM `brutes` WHERE `IP`='xxx.xxx.xxx.xxx';
insert your IP instead xxx.xxx.xxx.xxx. Is your IP there? If so,
Code:
mysql> DELETE FROM `brutes` WHERE `IP`='xxx.xxx.xxx.xxx';
that should remove your IP from the table and you will see that in mysql reply. Finally
Code:
mysql>quit
should return you to your usual prompt. HTH

` symbols are backticks, Above Caps Lock and Tab keys on a uk-gb keyboard, in some setups you can omit them
' symbol is the usual single quote
remember ; symbol after each line before pressing enter when you are in mysql prompt
this work for me, thanks a lot. :p