The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help my php.ini

Discussion in 'Workarounds and Optimization' started by Motasem, Jul 13, 2015.

  1. Motasem

    Motasem Member

    Joined:
    Jul 13, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    hi,

    any body may help me with my vps to configration PHP.ini

    this is my file:
    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    max_input_vars = 1000
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)


    ; Maximum size of POST data that PHP will accept.
    post_max_size = 8M
    Maximum allowed size for uploaded files.
    upload_max_filesize = 2M


    and it's so long.. so what should i do with my file?
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    What specifically are you trying to do?
     
  3. Motasem

    Motasem Member

    Joined:
    Jul 13, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    please i see this now in my websites
    Notice: Error: Out of resources when opening file '/tmp/#sql_2b6_0.MYI' (Errcode: 24)
    Error No: 23
    SELECT * FROM oc_information i LEFT JOIN oc_information_description id ON (i.information_id = id.information_id) WHERE id.language_id = '1' ORDER BY id.title in/home/myshopcom/public_html/store/system/library/db/mysqli.php on line 41Notice: Trying to get property of non-object in /home/myshopcom/public_html/store/admin/model/catalog/information.php on line 137
     
  4. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
  5. Motasem

    Motasem Member

    Joined:
    Jul 13, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    i do it.. i hope it's solve.. thank you very much

    another thing..
    please can you help me to configrate my.cnf ? to let my server work at the best shape without load

    this my.cnf

    [mysqld]
    port = 3306
    socket = /var/lib/mysql/mysql.sock
    skip-external-locking
    join_buffer_size = 2M
    max_heap_table_size = 256M
    tmp_table_size = 256M
    key_buffer_size = 128M
    max_allowed_packet=268435456
    table_open_cache = 512
    sort_buffer_size = 1M
    read_buffer_size = 1M
    read_rnd_buffer_size = 4M
    myisam_sort_buffer_size = 64M
    thread_cache_size = 8
    query_cache_size= 16M


    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency = 8
    #innodb_data_home_dir = /var/lib/mysql
    #innodb_data_file_path = ibdata1:10M:autoextend
    #innodb_log_group_home_dir = /var/lib/mysql
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    #innodb_buffer_pool_size = 256M
    #innodb_additional_mem_pool_size = 20M
    # Set .._log_file_size to 25 % of buffer pool size
    #innodb_log_file_size = 64M
    #innodb_log_buffer_size = 8M
    #innodb_flush_log_at_trx_commit = 1
    #innodb_lock_wait_timeout = 50

    open_files_limit=3048
    [mysqldump]
    quick
    max_allowed_packet = 16M

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [myisamchk]
    key_buffer_size = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M

    [mysqlhotcopy]
    interactive-timeout


    is there thing you advice me to change it?

    i have VPS, specifecation:
    - Removed -

    can you help please?
     
    #5 Motasem, Jul 13, 2015
    Last edited by a moderator: Jul 14, 2015
  6. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    run mysqltuner.pl. No one here knows enough about the usage and specs of your server to give you a blink "optimization" recommendation.
     
  7. Motasem

    Motasem Member

    Joined:
    Jul 13, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    i did it, and i see this:
    -------- Recommendations -----------------------------------------------------
    General recommendations:
    Run OPTIMIZE TABLE to defragment tables for better performance
    MySQL started within last 24 hours - recommendations may be inaccurate
    Enable the slow query log to troubleshoot bad queries
    Temporary table size is already large - reduce result set size
    Reduce your SELECT DISTINCT queries without LIMIT clauses
    Increase table_open_cache gradually to avoid file descriptor limits
    Read this before increasing table_open_cache over 64: http://bit.ly/1mi7c4C
    Variables to adjust:
    key_buffer_size (~ 31M)
    query_cache_size (> 16M)
    table_open_cache (> 512)
     
  8. gnusys

    gnusys Active Member

    Joined:
    Jan 18, 2013
    Messages:
    26
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please ensure you let MySQL run for at least 24 hours before running a tuning script to obtain the most accurate results.

    Thank you.
     
Loading...

Share This Page