cjm125

Member
Mar 15, 2007
5
0
151
Leeds (United Kingdom)
I urgently need your help!:confused: :confused: :confused:

I'm running cPanel on fedora, and have licensed through a third party so no tech support (apart from this forum) is included. I've just rebooted the server, the server is back online because I've got SSH access and can ping it, but nothing else is working! No web or mail, I need this sorting out urgently so anybody who think they can do it is quite welcome to have a go, I'll pay for time.

Thanks in advance,
Chris
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,217
4
193
Minneapolis, MN
II'm running cPanel on fedora, and have licensed through a third party so no tech support (apart from this forum) is included. I've just rebooted the server, the server is back online because I've got SSH access and can ping it, but nothing else is working! No web or mail
The first thing you should do is to check the log files /var/log/messages and /usr/local/apache/logs? for errors?
Did you restart httpd?
/scripts/restartsrv httpd
 

cjm125

Member
Mar 15, 2007
5
0
151
Leeds (United Kingdom)
Have tried restarting server using that command - still same.

Had a look /var/log/messages - everything seemed OK.

Had a look at the error_log file in /usr/local/apache/logs and found the following:

[Mon Mar 12 17:45:45 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Mon Mar 12 17:45:45 2007] [warn] NameVirtualHost 91.186.12.105:80 has no VirtualHosts
[Mon Mar 12 17:45:45 2007] [notice] Apache/1.3.37 (Unix) PHP/4.4.6 FrontPage/5.0.2.2635.SR1.2 configured -- resuming normal operations
[Mon Mar 12 17:45:45 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
[Mon Mar 12 17:45:45 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Mon Mar 12 17:46:09 2007] [notice] SIGHUP received. Attempting to restart


Does this point to a problem in the apache configuration?

Earlier on today I tried to upgrade my PHP version to PHP 5 through the software upgrade tool on cPanel. It spewed a couple of error messages out and PHP wouldn't work at all, so I tried to return it to the previous config.

This still didn't work so silly me, being used to windows, thought that if I did a graceful restart on the server it might sort it out, however this has happened.

Any help would be greatly appreciated.

Chris
 

jbiel

Member
Mar 14, 2007
6
0
151
[Mon Mar 12 17:45:45 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName


Appears apache has possibly lost some part of the configuration.

Feel free to contact me via PM for more help.
 

brendanrtg

Well-Known Member
Oct 4, 2006
311
0
166
1. Make sure the hostname is a FQDN, ie: A entry is set.
2. Hostname is set under WHM or under root.
3. Recompile Apache
 

cjm125

Member
Mar 15, 2007
5
0
151
Leeds (United Kingdom)
Problem solved!

Just a quick note to say that the problem is now solved.

Turned out all I needed to do was stop iptables.

Thank you very much to everybody who replied to this post and to Tim H at cpanelsource.com - your help was greatly appreciated and no doubt I'll be calling on it again some time in the not too distant future!

This is all a big learning curve for me but hopefully one day I'll be able to offer my help to some of the newbies on this board too!

Thanks,
Chris
 

mctDarren

Well-Known Member
Jan 6, 2004
662
6
168
New Jersey
cPanel Access Level
Root Administrator
Stopping iptables might be a fix, but not a solution. You shouldn't run a box without some form of firewall or you risk compromise. You should figure out what was causing the problem within your iptables ruleset and adjust it. Are you running a controller script, like APF or CSF?