The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help on Apache 2.2.6 + PHP 5.2.4

Discussion in 'EasyApache' started by InterServed, Sep 22, 2007.

  1. InterServed

    InterServed Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    255
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Upgraded today to latest current cpanel version and i've build apache 2.2.6 + php 5.2.4

    everything seems to be working just fine, tho while checking apache error logs i get a bit paranoid:

    [root@server01 (/usr/local/apache/logs)]# php -v
    PHP 5.2.4 (cli) (built: Sep 22 2007 16:56:51)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies


    [root@server01 (/usr/local/apache/logs)]# tail -f error_log
    [Sat Sep 22 20:46:05 2007] [info] [client xxx.xxx.xxx] (32)Broken pipe: core_output_filter: writing data to the network
    [Sat Sep 22 20:46:09 2007] [info] [client xxx.xxx.xxx] (32)Broken pipe: core_output_filter: writing data to the network
    [Sat Sep 22 20:46:11 2007] [info] [client ::1] (32)Broken pipe: core_output_filter: writing data to the network
    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: undefined symbol: ts_allocate_id
    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: undefined symbol: ts_allocate_id
    [Sat Sep 22 20:46:13 2007] [info] [client xxx.xxx.xxx] (32)Broken pipe: core_output_filter: writing data to the network
    [Sat Sep 22 20:46:25 2007] [info] [client xxx.xxx.xxx] (32)Broken pipe: core_output_filter: writing data to the network
    [Sat Sep 22 20:46:28 2007] [info] [client ::1] (32)Broken pipe: core_output_filter: writing data to the network
    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: undefined symbol: ts_allocate_id
    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: undefined symbol: ts_allocate_id


    No ideas why i get those errors, as ioncube seems to be working just fine.

    Some recommendations would really be appreciated, tired to see the error log growing so massivly with same errors.
     
  2. XzaB

    XzaB Active Member

    Joined:
    Nov 20, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Egypt, Cairo
    Hello,

    Although the name is correct, it looks like you've used the thread safe version of the Loader rather than the non ts one. I've verified that our 5.2 Loader build is correct (it would be but I checked anyway), and it's unlikely that our download packages mixed up the ts Loader with the non-ts one, Make sure that you use the ioncube_loader_lin_5.2.so file, and not the ioncube_loader_lin_5.2_ts.so file. If you're still stuck, please create a help desk ticket with Ioncube Support Team so their can help you.
     
    #2 XzaB, Sep 22, 2007
    Last edited: Sep 22, 2007
  3. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    The message below in the error_log isn't an error and it is only an information statement

    [Sat Sep 22 20:46:05 2007] [info] [client xxx.xxx.xxx] (32)Broken pipe: core_output_filter: writing data to the network

    This is commonly logged when a visitor clicks the stop button while a page is loading from your server.

    In regards to:

    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: /usr/local/ioncube/ioncube_loader_lin_5.2_ts.so: undefined symbol: ts_allocate_id

    I recommend reinstalling ioncube as this error usually occurs when the wrong ioncube loaders are installed and a fresh reinstall of ioncube should fix it. Make sure you reinstall the correct loaders for your system and arch.
     
  4. InterServed

    InterServed Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    255
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    php.ini part :

    [Zend]
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.0
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.0
    zend_optimizer.version=3.3.0
    zend_extension=/usr/local/ioncube/ioncube_loader_lin_5.2.so
    zend_extension_ts=/usr/local/ioncube/ioncube_loader_lin_5.2_ts.so (tried with and without)
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    Tho i tested app that needs ioncube and it works, just didn't understood why i get those error messages. However i will try to remove and download ioncube again.
     
  5. InterServed

    InterServed Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    255
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    After a complete rebuild of apache/php everything runs just perfect :)

    a happy user with apache 2.2.6/php 5.2.4
     
Loading...

Share This Page