The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help please ! Mail receiving problem

Discussion in 'E-mail Discussions' started by boku_baka, May 26, 2005.

  1. boku_baka

    boku_baka Registered

    Joined:
    May 26, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello Everyone
    I just setup a website and given cpanel acount. I manage to crate email account and send email flawlessly, but I got problem on receiving, Everytime an email is sent to my address it never got to mail boxes, When I set the "default address" for "unrouted mail" to my adreess (the default is ":blackhole:") I can receive that email. So anymail sent to my domain is considered as unrouted mail? How I can I solve this?
    Do I need to create a subdomain "mail.mywebsite.com"? how I do set this subdomain to handle all mail matter?
    Do I need to change Mail Exchaner (MX Entry) ? Or any other setting that I missed?
    Please help, I am new to all this. I really Appreciate anyhelp.
    Thank you very much !
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you set the catchall to anything other than the main account you need to setup a virtual POP3 Mail account for account@domain.com and then change your email client to account@domain.com instead of just account. You should also only use :fail: and not :blackhole:
     
  3. boku_baka

    boku_baka Registered

    Joined:
    May 26, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    hello..
    I don't quite understand your suggestion.. virtual pop3? (sorry, newbie here). btw, I dont have any client I am building a community site for my college, so it just a normal hosting where i have an account with cpanel but don't exactly control the machine/server.

    I was recommended to add a subdomain called mail.mysite.com and route the mail for my exchanger to that subdomain. It works, now everytime a make an account, it can send and receive mail normally. but problem accurs with my main account, it cannot receive email, again ! sigh..
    any idea? thanks before..
     
  4. ehpmahesh

    ehpmahesh Well-Known Member

    Joined:
    Jul 3, 2004
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    If you want all unrouted mail come to your mail box then you have to remove :blackhole: and you have to give your default mail or any mail. So that all unrouted mail will come to your given mail id.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    OK. There is an anomoly, which you're seeing here, with the way cPanel creates Mail (POP3) accounts. If you have your Default Address set to anoything other than your cPanel account name (account) then email will not be delivered to account anymore. You have to go into cPanel > Mail > Manage/Add/Remove Accounts > Add Account > and create a new account called account@yourdomain.com (this is the virtual account I was talking about). You then have to change your PC email client to login to account@yourdomain.com as the username instead of account which you would have used before.
     
  6. boku_baka

    boku_baka Registered

    Joined:
    May 26, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    thank you all,
    I'll give it a try. I getting to see a bright light here. :)
    but now it's already 3 rd days that my host is inaccessible due to "server upgrade..." well maybe i should consider to move to another host.. :mad:
     
Loading...

Share This Page