The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help pls: slow WHM/kernel/cpu or what ???

Discussion in 'General Discussion' started by ayik, Jan 26, 2005.

  1. ayik

    ayik Member

    Oct 7, 2004
    Likes Received:
    Trophy Points:
    My server is running in the most slowest ever these 3 days. Most process get on top of "top" especially those which require access to cpanel account database (plaintext or what?)

    [root@centaur hartono]# time /scripts/ftpupdate
    Ftp Password Files synced
    Vhost Passwords synced

    real 4m53.390s <-- usually much less than this
    user 4m17.342s
    sys 0m5.544s

    4:53 minutes is fast because now is night time (few users), at day time, ftpupdate/mkvhostpasswd can exists 6 minutes in the top process

    at 1st day, i saw there is total 40000 lines when i exec cat /etc/proftpd/* | wc -l and many of them are identical lines. so i removed them by using array_unique() from PHP. the result is now only about 10000 lines. But it did not fix the problem.

    When i log in into user cpanel (using xfercpanel), there is a top process called "cpanel", ate 95% CPU and when i'm viewing the source of blank unfinished cpanel index page in the web browser, the html code stopped in ...manage another account: .... <-- here should be the drop down list of user.

    So, i conclude, that my WHM/Cpanel is so strange. especially when processing user/accounting.

    One more, when the httpd started, it took about 5 minutes, and ate 90% of CPU too (running state)

    My total user is 1001 now. it was 1014 then i termintae unused 13 unused account. What confused me is that 4 days ago, it is running smoothly with 1000 account too.

    Is this kernel issue?
    My kernel is: Linux 2.6.10-1.9_FC2smp #1 SMP Thu Jan 13 18:15:45 EST 2005 i686 i686 i386 GNU/Linux.

    CPU is: Dual PIV (dont know HT or not HT) 2.8 GHz, 1GB RAM, 2x80 IDE HDD.

    WHM: WHM 10.0.0 cPanel 10.0.0-R7
    Fedora i686 - WHM X v3.1.0

    I am sorry i posted the same problem yesterday, i just feel desperate that the problem persist for 3 days, i dont know what to do tomorrow. i have read many posting too, i tried almost everything, but hasn't succeded yet

Share This Page