The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP PLZ - http://domain + http://www.domain same target using cpanel

Discussion in 'General Discussion' started by britishnproud, Feb 12, 2007.

  1. britishnproud

    britishnproud Registered

    Joined:
    Feb 12, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    West Yorkshire, England
    Hello ALL,

    I want to know how I can set-up my website / forum etc so that visitors arrive at the same URL regardless of whether www. is entered or not.

    I am sure it is possible but at the moment I can only use 1 or the other, not both.

    I am new to all cPanel settings so please be gentle and try not to use too much jargon, but that said please help.

    Thanks in advance,
     
  2. andy012345

    andy012345 Registered

    Joined:
    Jan 29, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    CPanel should do this by default. Make sure the domain the account created on doesn't include www, or it will work on www.www.domain and www.domain.
     
  3. britishnproud

    britishnproud Registered

    Joined:
    Feb 12, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    West Yorkshire, England
    Directory the cause ??

    Hello andy012345 and ALL,
    Thanks for your reply.

    I thought it shoiuld have been a default thing..
    When I go to my file manager I have a Directory called www in the root.

    Anything I put inside the root/www directory loads only with a http://www URL
    anything that goes into root/ will not load if I add www to the URL.

    Is there a way to reset the root so I can start again... Maybe when I was messing around trying to familiarise myself I caused the problem... I do not know.

    If I delete everything except for the .bash files and start again maybe I will not have the same problem...

    Also should I Upload all content inside the www directory or the root?? what is the difference?

    My Favicon works with / without www but not the index page.
     
Loading...

Share This Page