The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! prevent server accepting mail for other domains ?

Discussion in 'E-mail Discussions' started by 4u123, Jan 22, 2008.

  1. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I'm quite desperate for some help here. I've tried cpanel support but they dont seem to understand my question. Its not complicated...

    If I make an smtp session with one of my servers and attempt to send mail to it for a domain that is hosted on another one of my servers. The first server will lookup the domain and then send the email on.

    I'm not an expert on exim but that looks to me like the server is acting like an open relay. I simply need to stop the server from doing this. I only want it to accept mail for domains in the localdomains file.

    Can anyone please advise on what I need to do? Cpanel support told me to disable antirelayd - which is a completely unrelated and random answer.
     
    #1 4u123, Jan 22, 2008
    Last edited: Jan 22, 2008
  2. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I've spent alot of time looking into this today.

    Is there some kind of relay whitelist whereby the server will relay mail to any domain specificaly for the IP's in that list ?

    I tested connecting to the server via telnet from a number of desktop locations.
    Sending a RCPT TO always resulted in a 550 response for a domain not on the server.

    But if the connection is made from any of our servers or from any IP in our range - it will respond with a 250 when sending a RCPT To any random domain.

    Simple test from one of our servers to the server with this issue..


    Can someone please advise on how I can prevent this. I dont remember adding in the IP range to any whitelist or relay file.
     
    #2 4u123, Jan 22, 2008
    Last edited: Jan 22, 2008
  3. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    After all that trouble, it seems the ip range had been included in the following section of the exim config in WHM....

    Whitelist: Bypass all SMTP time recipient/sender/spam/relay checks

    I must have done that when very drunk because I sure as hell dont remember adding anything to that list!!

    Ahh well, we live and learn and make mistakes, some of us more than others haha.
     
Loading...

Share This Page