Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

HELP! Problem with :blackhole: on main email account

Discussion in 'E-mail Discussion' started by sprocket, Oct 12, 2002.

  1. sprocket

    sprocket Registered

    Joined:
    Aug 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    The scenario:

    website is website.com
    main login (and hence default e-mail address) is main@website.com.

    User doesn't want to use main@website.com as a catch-all e-mail account, but rather wants to delete messages that aren't sent to a valid e-mail address. User goes into cpanel and changes &default mail account for unrouted messages& to :blackhole:

    Problem:
    Now all mail sent to main@website.com is deleted (as is mail sent to aw34rasdfiljasdf@website.com). However, if there is an account on the site called monkey, then monkey@website.com receives direct-addressed mail just fine.

    It seems that setting up a function like :blackhole: or :fail: blocks the main@website.com e-mail account.

    Is there any way around this? Why isn't the main account considered a &registered& account? It would seem that the way this is supposed to work is: Message comes in, system checks to see if recipient has a valid e-mail address, and if so delivers it (and if not, deletes it). However, the &main& account doesn't seem to register as a valid e-mail address, and messages sent ot it head for the blackhole.

    Help! Any way to get around this??
     
  2. BJMG

    BJMG Active Member

    Joined:
    Jul 24, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    151
    You could edit the valias file for that specific domain. In the valias file, you should see a line which reads:

    *: {username}

    change it so it says
    *: &new-catch-all-account-name&

    Hope that helps
     
  3. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Atlanta, GA
    Removed due to confusion. See email further down.
     
  4. sprocket

    sprocket Registered

    Joined:
    Aug 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    How do I set bunchofjunk to be the catch-all account? (Only way I can immediately see to do that is to set the default account to point to it, but then I can't change the default account to blackhole).

    With there was a way to do it without using up another emailbox.
     
  5. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Atlanta, GA
    Sorry that was a bit confusing. Trying to do 5 things at once.

    I don't really see what your issue is. I think you are confused as to what the default address means. the default address is not the primary email address of the account; it just happens to be that by 'default', the default address is mapped to the primary email address for the account.

    The default address is simply a forwarder that will send any email to the address you specifiy if it doesn't match an email account on your system.

    If you set your default address to simply be :blackhole, then the system will only delete email that can't be routed to a real address/alias you have configured in the system. Assuming you have an account called main@domain.com, email will still go to that account as long as it is addressed to main@domain.com.

    Jaz
     
  6. sprocket

    sprocket Registered

    Joined:
    Aug 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    No, that's not the case. If my &default& address on the account is &main@whatever.com,& setting the &Default email address& to :blackhole: deletes both messages sent to addresses that don't exist AND messages sent to &main& (but not to other mailboxes.&)

    It seems that it is simply &replacing& the default catch-all address.

    I got around this by creating a duplicate mailbox, in additional to the primary Cpanel account, also called &main.& This seems to work -- but Horde has trouble logging in to that account (it sees two things named Main and freaks out).

    So, to clarify:

    Let's say my main user account is &main.& That means I log on to Cpanel using the username &main,& and that I have an automatic catch-all e-mail account created (the &Default E-mail Account&) also called main.

    If I change the default mail account -- using the Default Mail Account feature in Cpanel -- to :blackhole:, suddenly I can no longer get messages sent to main@website.com.

    (Try it, you'll see what I mean.)
     
  7. dandanfireman

    dandanfireman Well-Known Member
    PartnerNOC

    Joined:
    May 31, 2002
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    316
    I got around this by adding an additional alias (via command line)

    mainuser: mainuser@domain.com
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. sprocket

    sprocket Registered

    Joined:
    Aug 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    Hmmm. I don't have access to the command line. Just using Cpanel's forwarding feature, it appears to reject forwarding:

    mainuser : mainuser@website.com

    (Just refuses to save the forwarding request. Probably assuming it's redundant.)
     
  9. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    316
    If you don't have access to the command line then have your host/admin do it for you. If not that then you could always have mail sent to main@domain.com forward to a different popmail account.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice