AbeFroman

BANNED
Feb 16, 2002
654
1
318
Help!! Hello, my order form is not working, i have reason to believe it my be with the ssl i just installed. Do you know if thats true or how to fix it?

&This is a common proble, it has to do with the SSL server, from my experience with my webhosting company, this problem occurs when the server does a core dump because of problems in the OpenSSL library. The solution is too find another webhost who does not have this problem. Let me know if you have any questions.&

Hello,

I have 2 bugs, no error messages.

bug 1
this is my order form
https://securednshost.com/~anhostin/order/
but when i click on it from links in my site about one out of 10 times it goes to this
https://securednshost.com/%e7anhostin/order/


bug 2
one the order form about one in 10 times instead of going to the next page in the order form it goes to a
404 page not found
i hit reload it works fine or it i hit back and try it again it works fine.
 

rpmws

Well-Known Member
Aug 14, 2001
1,822
8
318
back woods of NC, USA
I had this problem back a year ago. I tried everything ..bashed my damn head through a brick wall and then it hit me. It's IE!!!! the 404 problem is caused by the way IE in-out flow screws up. You have to force apache down to ssl 1 like this in your httpd.conf.

#############################
#IE patch
SetEnvIf User-Agent &.*MSIE.*& \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
##############################

It fixed about 50 sites I had using SSL. all of them said that the 404 after form post was fixed.

Don't forget to restart Apache :)
 

AbeFroman

BANNED
Feb 16, 2002
654
1
318
tanks

Thanks,

you the man. That fixed bug 2.

Now if i can only fix bug 1
bug 1
this is my order form
https://securednshost.com/~anhostin/order/
but when i click on it from links in my site about one out of 10 times it goes to this
https://securednshost.com/%e7anhostin/order/
 

Michael Skaide

Registered
Aug 25, 2001
4
0
301
keepalive On or Off

What about the regular setting in httpd.conf when I use the following patch

#############################
#IE patch
SetEnvIf User-Agent &.*MSIE.*& \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
##############################

What's right for KeepAlive On or Off ???

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to &Off& to deactivate.
#
KeepAlive Off


Thank you

Michael