The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help setting up cgiemail

Discussion in 'E-mail Discussions' started by speedde, Jul 10, 2005.

  1. speedde

    speedde Registered

    Joined:
    Jul 7, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I've been trying to configure the cgiemail script to work for a very basic form, but I just can't get the action of the form correct. It should be "cgi-bin/cgiecho/template.txt" (where template is located at the root), but I keep getting a 404 error.
    I've tried many things but just can't get it to work. Any help would be very appreciated.
     
  2. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
  3. speedde

    speedde Registered

    Joined:
    Jul 7, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks but I've gone through those already. One thing tough, when I browse to domainname.com/cgi-bin/cgiemail I see a bunch of nonsense characters. I think it would mean that CGI isn't supported, but it should be. How do activate it?
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    have u checked if perl is working fine on your server ?

    u also need to check the ScriptAlias at the httpd conf file.

    another thing is to put up a sample perl scipt and try executing.

    as u have said that the u see some junk charecters on screen, i suppose something is happening, and hence would test it with a sample script with exact permissions on the file.
     
  5. speedde

    speedde Registered

    Joined:
    Jul 7, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I tried a script and got this error message:

    Internal server error
    The server encountered an internal error or misconfiguration and was unable to complete your request

    Apparently something isn't configured correctly. What is this httpd file you are talking about? I cannot find such a file.
     
  6. paralard

    paralard Well-Known Member

    Joined:
    Mar 2, 2003
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin Texas
    This is what the cgiemail looks like

    ^?ELF^A^A^A^@^@^@^@^@^@^@^@^@^B^@^C^@^A^@^@^@P<8e>^D^H4^@^@^@<94>B^@^@^@^@^@^@4^@ ^@^F^@(^@^]^@^\^@^F^@^@^@4^@^@^@4<80>^D^H4<80>^D^HÀ^@^@^@À^@^@^@^E^@^@^@^D^@^@^@^C^@^@^@ô^@^@^@ô<80>^D^Hô<80>^D^H^S^@^@^@^S^@^@^@^D^@^@^@^A^@^@^@^A^@^@^@^@^@^@^@^@<80>^D^H^@<80>>^@^@g>^@^@^E^@^@^@^@^P^@^@^A^@^@^@h>^@^@hÃŽ^D^HhÃŽ^D^H°^A^@^@l^B^@^@^F^@^@^@^@^P^@^@^B^@^@^@x?^@^@xÃ^D^HxÃ^D^HÂ*^@^@^@Â*^@^@^@^FD^@^@^@^D^@^@^@^H^A^@^@^H<81>^D^H^H<81>^D^H ^@^@^@ ^@^@^@^D^@^@^@^D^@^@^@/lib/ld-linux.so.2^@^@^D^@^@^@^P^@^@^@^A^@^@^@GNU^@^@^@^@^@^B
     
    #6 paralard, Aug 8, 2005
    Last edited: Aug 8, 2005
  7. paralard

    paralard Well-Known Member

    Joined:
    Mar 2, 2003
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin Texas
    It is not the ScriptAlias for me. I have checked and it is there.....

    httpd.conf is located here FYI

    /etc/httpd/conf/httpd.conf
     
  8. shashank

    shashank Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    159
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Modify the domain for the package to have cgi support enabled.
     
Loading...

Share This Page