Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Help ! SSL not working

Discussion in 'General Discussion' started by Radio_Head, Apr 11, 2002.

  1. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    343
    SSL is not working on my site , https:// doesn't work .
    What I have to do to reconfigure it or what can i do to make it
    work again ? May I reinstall openSSL ?

    Any help appreciated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    343
    I tried to restart the server and now https works fine only whm on port 2087 . https does not work on all other ip addresses on port 80 , please help !!!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    343
    I analyzed the /usr/local/apache/logs/ssl_engine_log file ,
    and there is no error reported

    I analyzed the /usr/local/apache/logs/error_log

    and I noticed the following error when I attempted to call
    an ip address or a domain name with https://
    &Invalid method in request&

    Finally I tried from shell
    httpd startssl

    and no problem has been reported .


    Any suggestion ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    343
    I contacted dialtone (my dedicated server provider) and they replied that the problem is not on their end because they was able to open my ip addresses using port 443 (?)

    Please HELP !!!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    343
    anyone can help me ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    343
    I found the solution .
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. saj

    saj Member

    Joined:
    Nov 6, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    151
    Hi radiohead,

    Please tell me how u solved the issue. I am facing the same issue
     
  8. sumith

    sumith Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    96
    Likes Received:
    2
    Trophy Points:
    158
    hello guys,

    Please check whether apf is installed on the server, and if it is installed, check the file /etc/apf/conf.apf and check whether port 443 is blocked. Also, check for other firewall settings if there any block setup for the port 443.
    If so, disable it and try the same again.

    If there is no firewall blocks on the server, try the command


    /usr/local/apache/bin/httpd startssl

    service httpd stop

    service httpd start

    When I did the above steps, the issue got resolved

    Regards,
    sumith
    sumith@sumith.net
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Kerstin

    Kerstin Well-Known Member

    Joined:
    Apr 9, 2005
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Berlin
    The commands ;)

    /usr/local/apache/bin/httpd startssl
    service httpd stop
    service httpd start

    should clear the blocked port 443 and walking fine.

    :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice