Help, SSL setup not working, only 1 SSL Host can be created

ayik

Member
PartnerNOC
Oct 7, 2004
15
0
151
Hi,

I have weird WHM when installing SSL Host. It is only the 1st configured SSL Host that working, and the others were not working (only 1 SSL host in 1 server). I checked httpd.conf and found only one too lines like this:

<IfDefine SSL>
<VirtualHost xxx.xxx.xxx.xxx:443>
ServerAdmin [email protected]
DocumentRoot /home/xxxxx/public_html
ServerName secure.txxxxxxxxx.net
CustomLog /usr/local/apache/domlogs/secure.txxxxxxx.net-ssl_log "%t %{version}c %{cipher}c %{clientcert}c"
User txxxxx
Group txxxxx
.....
</IfDefine SSL>

The others didn't configured successfully.
found lines like this:
<IfDefine SSL>
</IfDefine SSL>

Is this WHM errors? how can i fix it? Cause it will take longer time to configure an SSL manually.

Oh, one more: While setting up the SSL host, found an error message "error 18 at 0 depth lookup":

Attempting to verify your certificate..... Cerificate verification passed!
Verifcation Result [/C=ID/ST=DKI/L=Jakarta/O=Txxxxxx/OU=webssl/CN=secure.txxxxxx.net/[email protected] error 18 at 0 depth lookup:self signed certificate OK]

The Certificate for the domain secure.txxxxxxx.net was installed on the ip xxx.xxx.xxx.xxx.

Attempting to restart httpd
....
httpd started ok

Thanks before
 

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
Are you putting each certificate on a domain with its own IP ? ( ie, not shared IP, but rather dedicated as is required. )
 

ayik

Member
PartnerNOC
Oct 7, 2004
15
0
151
Hmm.. I put it all in one IP address. So.. is this cause the problem?

If did, Can we have all SSL hosts in a shared IP?