The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help. Unable to send via SMTP

Discussion in 'E-mail Discussions' started by thernes, Dec 3, 2007.

  1. thernes

    thernes Active Member

    Joined:
    Dec 29, 2001
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bodo, Norway
    All of a sudden none of the users on my cpanel boxes can send e-mail using their mail clients via SMTP. No problems receiving, but no go on the outgoing mail. Everything works just fine using the webmail. No changes have been done on the server lately, except for the automated cpanel updates. CFS installed and set up to allow connections on port 25. Just to make sure this was not a firewall issue, the firewall was disabled and no difference.
    Looks like the connection can not be made properly, as no new entires show up in /var/log/maillog when I try sending.

    Need some help solving this one and a couple of ideas on where I should start to look.

    Edit to add: No, my ISP does not block port 25
     
    #1 thernes, Dec 3, 2007
    Last edited: Dec 3, 2007
  2. thernes

    thernes Active Member

    Joined:
    Dec 29, 2001
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bodo, Norway
    Just gonna add some more info here: Everything works just fine when I set exim to also listen to port 26. When I try to telnet to port 25 on my boxes, the connection fails, but no problem connection to other smtp servers (like my ISP's) on port 25.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Note that ISPs will allow port 25 connections to their own mail server. It's when it's not their mail server that port 25 traffic tends to be blocked.
     
  4. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    We are also experiencing timeouts only for the last couple of days.

    My server monitoring is showing timeouts and we are getting complaints from customers that they cant connect when sending.

    This seems ot be affecting about 8 of our servers. We havent made any changes at all.

    Have there been some exim changes in the last couple of days in release ?

    We are on 11.15.0-R18264
     
  5. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    :)

    same issue here I also noticed when was port 26 taken out of tweak settings in server configuration
     
  6. jarodlwk

    jarodlwk Active Member

    Joined:
    Sep 24, 2006
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    you need to check with your customer if they are using an ISP that blocks port 25. I have the same issue but it turns out the end users' ISP blocks port 25 to combat spam. We had to enable port 26 for these users to send mails.
     
  7. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    For me it was a DNS resolution issue causing the problem.
     
Loading...

Share This Page