Help understanding failed PECL OAuth module install

airaid

Member
Feb 18, 2014
23
1
3
cPanel Access Level
Root Administrator
CENTOS 6.7 x86_64, WHM 11.52.1 (build 3), PHP 5.4.45, Apache 2.2.31

I need to use OAuth in my PHP application and, from what I've read, I need install the PECL OAuth module. I've tried this using WHM > Software > Module Installers but unfortunately this fails with the below message. Same result using command line.

Can anyone offer more insight into getting OAuth up and running?

Many thanks.

Code:
downloading oauth-1.2.3.tgz ...
Starting to download oauth-1.2.3.tgz (45,531 bytes)
.............done: 45,531 bytes
6 source files, building
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
building in /root/tmp/pear/pear-build-root7wJF0f/oauth-1.2.3
running: /root/tmp/pear/oauth/configure --with-php-config=/usr/local/bin/php-config
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20100525
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for oauth support... yes, shared
checking for cURL in default path... cURL not found
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1966080
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /root/tmp/pear/pear-build-root7wJF0f/oauth-1.2.3/libtool --mode=compile cc  -I. -I/root/tmp/pear/oauth -DPHP_ATOM_INC -I/root/tmp/pear/pear-build-root7wJF0f/oauth-1.2.3/include -I/root/tmp/pear/pear-build-root7wJF0f/oauth-1.2.3/main -I/root/tmp/pear/oauth -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2 -Wall -g   -c /root/tmp/pear/oauth/oauth.c -o oauth.lo
mkdir .libs
cc -I. -I/root/tmp/pear/oauth -DPHP_ATOM_INC -I/root/tmp/pear/pear-build-root7wJF0f/oauth-1.2.3/include -I/root/tmp/pear/pear-build-root7wJF0f/oauth-1.2.3/main -I/root/tmp/pear/oauth -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -Wall -g -c /root/tmp/pear/oauth/oauth.c  -fPIC -DPIC -o .libs/oauth.o
In file included from /root/tmp/pear/oauth/php_oauth.h:47,
                 from /root/tmp/pear/oauth/oauth.c:14:
/usr/local/include/php/ext/pcre/php_pcre.h:29:18: error: pcre.h: No such file or directory
In file included from /root/tmp/pear/oauth/php_oauth.h:47,
                 from /root/tmp/pear/oauth/oauth.c:14:
/usr/local/include/php/ext/pcre/php_pcre.h:37: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
/usr/local/include/php/ext/pcre/php_pcre.h:38: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
/usr/local/include/php/ext/pcre/php_pcre.h:44: error: expected specifier-qualifier-list before 'pcre'
/root/tmp/pear/oauth/oauth.c: In function 'oauth_compare_key':
/root/tmp/pear/oauth/oauth.c:507: warning: assignment discards qualifiers from pointer target type
/root/tmp/pear/oauth/oauth.c:516: warning: assignment discards qualifiers from pointer target type
make: *** [oauth.lo] Error 1
ERROR: `make' failed
The oauth.so object is not in /usr/local/lib/php/extensions/no-debug-non-zts-20100525
Tidying /usr/local/lib/php.ini...
No changes
Tidying /usr/local/cpanel/3rdparty/php/54/etc/php.ini...
No changes
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello :)

Try installing the prce-devel package first and then attempt to install this PECL module again:

Code:
yum install pcre-devel
Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.