The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help with email settings

Discussion in 'E-mail Discussions' started by Antifreeze, Aug 18, 2008.

  1. Antifreeze

    Antifreeze Member

    Joined:
    Jul 28, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I'm an end-user with cpanel on my webspace. I made the following mistake which apparently broke my account. I'd like any WHM experts to take a look at the two problems below, and tell me if there is a way to undo the damage in the WHM settings without re-setting the account:

    I wanted to redirect webmail.domain.net (which uses port 80) directly to roundcube rather than display the email 'splash' page. During the course of experimenting, I created and deleted the subdomains 'webmail' and 'mail' in my public_html directory. Cpanel didn't like this and:

    · switched off the webmail.domain.net feature
    · chnaged my webserver from 'mail.domain.net' to 'domain.net'

    My host wants to reset my account to fix it, but also says that my home directory backup cannot be used after resetting because it may re-introduce the account corruption. This means that I'll lose all my company's email accounts, passwords and hundreds of megabytes of stored email.

    Is there any way to un-do the damage without resetting the account?
    I trust my host, and they are probably right, but I'm desperate to find a way out of this mess.

    Thanks.

    NB: moderators - please don't consider this a crosspost. Although the same problem is described in another thread, it asks about solving the problem through manually uploading email directories *after* an account reset. THIS thread is about whether the problem can solved through WHM settings *without* resetting the account.
     
  2. Antifreeze

    Antifreeze Member

    Joined:
    Jul 28, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    OK, I've had a couple of research breakthroughs with this.

    A reminder of the issue: I inadvertently created 'mail' and 'webmail' sub-directories without knowing that it would break my account's default behaviour.

    Firstly, my email server does not now respond to 'mail.domain.net' anymore, but simply 'domain.net'. After much research, I have come to the conclusion that when I created the subdomain 'public_html/mail', cpanel simply changed the MX entry in my zone file from mail.domain.net to domain.net, and this can easily be corrected by editing the zone file.

    Can anyone confirm this?

    Secondly, when I created the 'webmail' subdomain, it over-rides something called a 'subdomain proxy'. There are several such proxies: webmail, cpanel, webdisk and whm. Usually they are configured in the 'whm -> tweak settings' options and are generated when an account is created.

    However, there is a WHM script called proxydomains which adds them into *existing* accounts. Running:
    /scripts/proxydomains '--user=username add'
    in apache should add the proxydomains back to my account.

    Can anyone confirm this?

    Thanks for any assistance.
     
  3. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    mail.domainname will not be working because DNS entry for it is not existing. This happenes NOT because cpanel changes the MX automatically. MX will remain same.

    you can check with the command

    dig mx domainname


    So, it looks like you deleted the mail.domainname subdomain. What your host have to do is, just add an A record for mail.domainname in the dns zone for domainname.

    Similaly to fix that webmail proxy problem, just delete the subdomain you created and ask your host to add an A record for webmail.domainname also. That should fix the problem.
     
  4. Antifreeze

    Antifreeze Member

    Joined:
    Jul 28, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply.

    > What your host have to do is, just add an A record for
    > mail.domainname in the dns zone for domainname

    Referring to this image (because I've never seen the WHM interface):
    http://www.reachcustomersonline.com/images/byline/whm_dns_1024.jpg

    Can I confirm with you that the mx record should be: mail.domain.net. ?
    And should there also be an 'A' record with simply 'mail' ?

    > Similarly to fix that webmail proxy problem, just delete the subdomain
    > you created and ask your host to add an A record for webmail.domainname

    That would be great!
    But my host says that would restore the DNS entry only, not the apache configuration for the domain.


    Thanks.
     
    #4 Antifreeze, Aug 19, 2008
    Last edited: Aug 19, 2008
  5. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    >>Can I confirm with you that the mx record should be: mail.domain.net. ?
    >>And should there also be an 'A' record with simply 'mail' ?

    Yes, that is correct.

    >>That would be great!
    But my host says that would restore the DNS entry only, not the apache configuration for the domain.

    No, that is not correct. Because, when you delete the subdomain, the etnry for subdomain webmail.domainname will be deleted from apache conf. So, it will not go to the webmail foder under your account any more and will load webmail directly.
     
Loading...

Share This Page