Help with installing Ruby On Rails

mm1250

Well-Known Member
Nov 10, 2006
108
0
166
Hello all,

I have a simple question I think. I'm trying to install Ruby on Rails but I seem to be getting stuck with the 1st step :(

I'm following the instructions via the cPanel install guide:
http://www.cpanel.net/docs/ror/index.html

The problem is when i run this command in SSH:

[email protected] [/]# yum list ruby
bash: yum: command not found

Sounds kinda stupid, but I though Yum is installed on the server. Am I doing something wrong? This is a dedicated server from ThePlanet i had for about a year.

Note I'm a Newbie so please go easy on me :eek:
 

mm1250

Well-Known Member
Nov 10, 2006
108
0
166
WHM 11.11.0 cPanel 11.16.0-S18450
REDHAT Enterprise 4 i686 on standard - WHM X v3.1.0
 

thewird

Well-Known Member
Jan 4, 2006
54
0
156
Toronto
If yum isn't on your server, you need to contact your system admin to fix it. Why people run redhat for servers is beyond me.

thewird
 

mm1250

Well-Known Member
Nov 10, 2006
108
0
166
Hello,

I ran the installer and it seemed to do all the stuff and I also did afterwards /usr/local/cpane/bin/ror_setup but I got all these errors that came up:

[email protected] [/home/admin]# /usr/local/cpanel/bin/ror_setup
Can't locate Cpanel/Class/Meta/Class.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/siperl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/55 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/50 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/Cpanel/Class.pm line 9.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Class.pm line 9.
Compilation failed in require at /usr/local/cpanel/Cpanel/Init/Factory.pm line 4.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Init/Factory.pm line 4.
Compilation failed in require at /usr/local/cpanel/Cpanel/Init.pm line 4.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Init.pm line 4.
Compilation failed in require at /usr/local/cpanel/bin/ror_setup line 5.
BEGIN failed--compilation aborted at /usr/local/cpanel/bin/ror_setup line 5.

I went and logged into cPanel but the only theing that shows is RubyGems. I also checked the feature manager and Ruby On Rails is checked. So something happened I think to the install.
 

smile

Well-Known Member
Oct 2, 2004
68
0
156
Hello,

I ran the installer and it seemed to do all the stuff and I also did afterwards /usr/local/cpane/bin/ror_setup but I got all these errors that came up:

[email protected] [/home/admin]# /usr/local/cpanel/bin/ror_setup
Can't locate Cpanel/Class/Meta/Class.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/siperl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/55 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/50 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/Cpanel/Class.pm line 9.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Class.pm line 9.
Compilation failed in require at /usr/local/cpanel/Cpanel/Init/Factory.pm line 4.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Init/Factory.pm line 4.
Compilation failed in require at /usr/local/cpanel/Cpanel/Init.pm line 4.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Init.pm line 4.
Compilation failed in require at /usr/local/cpanel/bin/ror_setup line 5.
BEGIN failed--compilation aborted at /usr/local/cpanel/bin/ror_setup line 5.

I went and logged into cPanel but the only theing that shows is RubyGems. I also checked the feature manager and Ruby On Rails is checked. So something happened I think to the install.
I get the same problem, has anybody been able to resolve this ?
 

sirotex

Well-Known Member
Jul 10, 2008
121
0
66
Hehe...Linux? really...use FreeBSD..

Also if you cannot understand whats wrong when it says no command found for yum, you seriously should re-think having your own Server..
 

SoftDux

Well-Known Member
May 27, 2006
1,023
5
168
Johannesburg, South Africa
cPanel Access Level
Root Administrator
Hehe...Linux? really...use FreeBSD..

Also if you cannot understand whats wrong when it says no command found for yum, you seriously should re-think having your own Server..
Actually, I know FreeBSD & Linux equally well. But seeing that the FreeBSD users on this forum makes themselve superior to everyone else, I can see wht no one wants to help someone who doesn't necesarely work with his server the same way you do. And not everyone is a hacker, so not every should know every little ounce of detail of a server.

Anyone Please????????? Why no one want's to help for?
mm1250, you will need to install yum manually before using it. Doing a google for "How to install yum manually on Redhat Linux", I got the following:

http://imountain.com/blog/2008/09/13/how-to-install-yum-manually-on-redhatrhel-4x-or-centos-4x/


This also seem useful:

http://sial.org/howto/yum/
http://blog.eukhost.com/webhosting/install-yum-utility-on-redhat-4/