The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with IonCube

Discussion in 'General Discussion' started by Denni, Jul 25, 2011.

  1. Denni

    Denni Registered

    Joined:
    Jul 25, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,I have a dedicated server and i have 5-6 having problems with that.
    i have go to >Tweak Settings >PHP and chooiced "iocube " like default but again and again having the same problems.
    i also runed the install commands of Zend or IonCube but it showed me like installed.
    i Also restarted the server but again showing me the same.
    Any Suggestions?
     
  2. lijeeshsd

    lijeeshsd Active Member

    Joined:
    Apr 22, 2005
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    You can enable IonCube for PHP by running following command from SSH:

    /scripts/phpextensionmgr install IonCubeLoader
     
  3. Denni

    Denni Registered

    Joined:
    Jul 25, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,i have installed that but it dosnt work since they are installed from the beggining.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What is the issue here exactly? You mention it shows installed, but not what error you are receiving or why you believe it isn't installed. What is happening to indicate that you don't believe it is properly installed?

    Of note, if you are using suPHP or have an individual php.ini file on an account and that php.ini file is incomplete (it doesn't contain the full /usr/local/lib/php.ini contents), the account will strip IonCube and other modules similar to that in it so that those don't appear. You would need to fix that by copying the /usr/local/lib/php.ini file to the user's account and then editing that full php.ini file.
     
Loading...

Share This Page