The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with my nameserver / dedicated setup

Discussion in 'Bind / DNS / Nameserver Issues' started by dean.woodford, Oct 3, 2012.

  1. dean.woodford

    dean.woodford Registered

    Joined:
    Oct 3, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I am relatively new to managing cpanel/whm and setting up the DNS etc.....

    I have a dedicated server with godaddy, several websites will be hosted here, all of the domains are registered at mtgsy.net.

    I have already set up nameservers with a domain, ns3.apazine.com and ns4.apazine.com. I have (too the best of my ability) set up the nameserver information in WHM.

    However, the domains are still unreachable. this http://www.intodns.com/apazine.net may shed some light, i can understand alot of the information but not what or where the problem is. In my opinion, it looks like the server is not responding to the nameserver requests properly.

    The nameservers each have an ip. Please please please can anyone shed some light, point me in the direction to help. I have searched high and low on the net and not found a tutorial that works. I have emailed godaddy but with no joy.

    I simply want to use the nameserver ns3.apazine.com and ns4.apazine.com on my dedicated, assign these NS to all accounts so that all domains i point using these NS will load at the dedicated server.

    Many thanks in advance.
     
  2. Thomas C. Stowe

    Thomas C. Stowe Registered

    Joined:
    Oct 3, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    San Antonio, Texas, United States
    cPanel Access Level:
    Root Administrator
    I'm having the exact same problem.

    http://www.intodns.com/2wheeloutlet.com

    I've checked much of everything, from the WHM Zone File settings and /etc/named.conf, /etc/resolv.conf, /etc/nameserverips, /var/cpanel files relating to it and even the IPTables rules making sure port 53 UDP and TCP is open for requests. Yet, the nameservers I've set up won't respond.

     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you continue to experience the same problem after deleting and then recreating the DNS Zone?

    Feel free to open a support ticket for additional assistance:

    Submit A Ticket

    You can post the ticket number here so we can report back what the resolution was.

    Thank you.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Of note, port 953 also needs to be opened for UDP and TCP traffic rather than only port 53. If you don't have 953 opened, then DNS queries won't function for the zones.

    Next, you also need to ensure that the nameservers are in the main DNS zone for the domain and have not only NS setup for them but also A records for the IP for the nameservers:

    domain.com 14400 IN NS ns1.domain.com.
    domain.com 14400 IN NS ns1.domain.com.
    ns1 14400 IN A IP#
    ns2 14400 IN A IP#

    Where domain.com is the domain name for the nameserver main domain, and IP# is the IP# for each nameserver.
     
Loading...

Share This Page